summaryrefslogtreecommitdiff
path: root/dev-haskell/colour/colour-2.3.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/colour/colour-2.3.6.ebuild')
-rw-r--r--dev-haskell/colour/colour-2.3.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/colour/colour-2.3.6.ebuild b/dev-haskell/colour/colour-2.3.6.ebuild
new file mode 100644
index 000000000000..5095e74b2b59
--- /dev/null
+++ b/dev-haskell/colour/colour-2.3.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A model for human colour/color perception"
+HOMEPAGE="https://www.haskell.org/haskellwiki/Colour"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+CABAL_CHDEPS=(
+ 'random >= 1.0 && < 1.2' 'random >= 1.0'
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/random-1.0
+ >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4
+ )
+"
+
+pkg_pretend() {
+ if use test; then
+ ewarn "The \"test\" USE flag for this package creates cycles within the"
+ ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
+ ewarn "It is recommended to leave it disabled unless explicitly testing the package."
+ fi
+}