summaryrefslogtreecommitdiff
path: root/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.101.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.101.0.ebuild')
-rw-r--r--dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.101.0.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.101.0.ebuild b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.101.0.ebuild
index 767f820e8d87..3c2252862587 100644
--- a/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.101.0.ebuild
+++ b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.101.0.ebuild
@@ -29,14 +29,12 @@ DEPEND="${RDEPEND}
>=dev-haskell/tasty-quickcheck-0.8 )
"
-src_prepare() {
- cabal_chdeps \
- 'base >= 4.5 && < 4.11' 'base >= 4.5' \
- 'tasty == 0.11.*' 'tasty >= 0.11' \
- 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8' \
- 'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9'
- default
-}
+CABAL_CHDEPS=(
+ 'base >= 4.5 && < 4.11' 'base >= 4.5'
+ 'tasty == 0.11.*' 'tasty >= 0.11'
+ 'tasty-quickcheck == 0.8.*' 'tasty-quickcheck >= 0.8'
+ 'tasty-hunit == 0.9.*' 'tasty-hunit >= 0.9'
+)
src_configure() {
haskell-cabal_src_configure \