summaryrefslogtreecommitdiff
path: root/dev-haskell/gluraw/gluraw-2.0.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/gluraw/gluraw-2.0.0.4.ebuild')
-rw-r--r--dev-haskell/gluraw/gluraw-2.0.0.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/gluraw/gluraw-2.0.0.4.ebuild b/dev-haskell/gluraw/gluraw-2.0.0.4.ebuild
new file mode 100644
index 000000000000..f13939c1cdcd
--- /dev/null
+++ b/dev-haskell/gluraw/gluraw-2.0.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.6.9999
+#hackport: flags: -usenativewindowslibraries
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="GLURaw"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A raw binding for the OpenGL graphics system"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/openglraw-3.0:=[profile?] <dev-haskell/openglraw-3.4:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ virtual/glu
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-usenativewindowslibraries
+}