summaryrefslogtreecommitdiff
path: root/dev-haskell/optparse-applicative/optparse-applicative-0.18.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/optparse-applicative/optparse-applicative-0.18.1.0.ebuild')
-rw-r--r--dev-haskell/optparse-applicative/optparse-applicative-0.18.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/optparse-applicative/optparse-applicative-0.18.1.0.ebuild b/dev-haskell/optparse-applicative/optparse-applicative-0.18.1.0.ebuild
new file mode 100644
index 000000000000..69832dbebf11
--- /dev/null
+++ b/dev-haskell/optparse-applicative/optparse-applicative-0.18.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +process
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Utilities and combinators for parsing command line options"
+HOMEPAGE="https://github.com/pcapriotti/optparse-applicative"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/prettyprinter-1.7:=[profile?] <dev-haskell/prettyprinter-1.8:=[profile?]
+ >=dev-haskell/prettyprinter-ansi-terminal-1.1:=[profile?] <dev-haskell/prettyprinter-ansi-terminal-1.2:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.8:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/quickcheck-2.8 <dev-haskell/quickcheck-2.15
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=process
+}