summaryrefslogtreecommitdiff
path: root/dev-haskell/recaptcha/recaptcha-0.1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/recaptcha/recaptcha-0.1.0.4.ebuild')
-rw-r--r--dev-haskell/recaptcha/recaptcha-0.1.0.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/recaptcha/recaptcha-0.1.0.4.ebuild b/dev-haskell/recaptcha/recaptcha-0.1.0.4.ebuild
new file mode 100644
index 000000000000..77661085baed
--- /dev/null
+++ b/dev-haskell/recaptcha/recaptcha-0.1.0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.6
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Functions for using the reCAPTCHA service in web applications"
+HOMEPAGE="https://github.com/jgm/recaptcha/tree/master"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/http-3001.1.4:=[profile?]
+ >=dev-haskell/xhtml-3000.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}