summaryrefslogtreecommitdiff
path: root/dev-haskell/vector-builder/vector-builder-0.3.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/vector-builder/vector-builder-0.3.8.ebuild')
-rw-r--r--dev-haskell/vector-builder/vector-builder-0.3.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/vector-builder/vector-builder-0.3.8.ebuild b/dev-haskell/vector-builder/vector-builder-0.3.8.ebuild
new file mode 100644
index 000000000000..5c2ac8cc49f5
--- /dev/null
+++ b/dev-haskell/vector-builder/vector-builder-0.3.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Vector builder"
+HOMEPAGE="https://github.com/nikita-volkov/vector-builder"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="<dev-haskell/base-prelude-2:=[profile?]
+ >=dev-haskell/semigroups-0.16:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ >=dev-haskell/vector-0.11:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( >=dev-haskell/attoparsec-0.13 <dev-haskell/attoparsec-0.14
+ >=dev-haskell/quickcheck-2.8.1 <dev-haskell/quickcheck-3
+ >=dev-haskell/quickcheck-instances-0.3.11 <dev-haskell/quickcheck-instances-0.4
+ <dev-haskell/rerebase-2
+ >=dev-haskell/tasty-0.12 <dev-haskell/tasty-2
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.9 <dev-haskell/tasty-quickcheck-0.11 )
+"