summaryrefslogtreecommitdiff
path: root/dev-haskell/witherable/witherable-0.4.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/witherable/witherable-0.4.2-r1.ebuild')
-rw-r--r--dev-haskell/witherable/witherable-0.4.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/witherable/witherable-0.4.2-r1.ebuild b/dev-haskell/witherable/witherable-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..6fb6284e0924
--- /dev/null
+++ b/dev-haskell/witherable/witherable-0.4.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="filterable traversable"
+HOMEPAGE="https://github.com/fumieval/witherable"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/base-orphans-0.8.4:=[profile?] <dev-haskell/base-orphans-0.10:=[profile?]
+ >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/indexed-traversable-0.1.1:=[profile?] <dev-haskell/indexed-traversable-0.2:=[profile?]
+ >=dev-haskell/indexed-traversable-instances-0.1:=[profile?] <dev-haskell/indexed-traversable-instances-0.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.12.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.12.2.0:=[profile?] <dev-haskell/vector-0.14:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/quickcheck-2.14.2
+ dev-haskell/quickcheck-instances
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck
+ )
+"