summaryrefslogtreecommitdiff
path: root/dev-java/colt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/colt')
-rw-r--r--dev-java/colt/Manifest5
-rw-r--r--dev-java/colt/colt-1.2.0-r3.ebuild45
-rw-r--r--dev-java/colt/files/colt-1.2.0-benchmark-no-deprecation.patch31
-rw-r--r--dev-java/colt/files/colt-1.2.0-remove-concurrent-util-imports.patch210
-rw-r--r--dev-java/colt/metadata.xml8
5 files changed, 0 insertions, 299 deletions
diff --git a/dev-java/colt/Manifest b/dev-java/colt/Manifest
deleted file mode 100644
index 8ea091563cb5..000000000000
--- a/dev-java/colt/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX colt-1.2.0-benchmark-no-deprecation.patch 1180 BLAKE2B 748b1d14c0982ceb1d703cbf7dd478428c406afb0ae34ed22faf10fc93b97c36ff9d6764ac4b57057eabe4e85984fa5a650b9c65d24e0420e99a81046a67b1b9 SHA512 523a887bc104062a22ecb4e4350c1c8a4a0be642490b98770943b20e6e8e747d95657d10d042198516b2fd830feb0987ff3473b8ab83278ad3db57d29e9239c7
-AUX colt-1.2.0-remove-concurrent-util-imports.patch 6924 BLAKE2B 9ceaed0b61e0e8510d49c2151b9c42f2f125f42592ab98e8fd95812e0af572a8675b18642d103add8dbbec003683fe0d8b32e942a613a46245f3595a1c0827aa SHA512 86b568d66b342ede74dc3207268675c8f91b6b3dcc622486d649ba6a0a283de8b20a46f4ac16da8d90d89b4af603b1c8378b990866123e8e4b8b4e3733be4a36
-DIST colt-1.2.0.tar.gz 2545695 BLAKE2B be5a1e2ca50650a3dfe003855801350f4b01b931b11b59f41e635c4daeb011b7a761a7db8532168157bfbfac5a4473a39e0b49698d9ccd32e0099149dd7d4adb SHA512 a5e88e0cf671faeb336241d120daeb1ad90f1e2061827d06c0c2dc507cd3ae2ab45f2b80451aaedca0f5a8b3de66c13533178e3b6352ed8b2df886d25a924ce0
-EBUILD colt-1.2.0-r3.ebuild 1055 BLAKE2B b86752fc0929982fbd53b96eee06bc23bf89bcd9dd4b6131574e2692d754b3f78d5aedb7711958d4f26a1e73153875e9862a5ab587fda6259cae3c1184766a88 SHA512 7eb72ee23d2bee8f26f68a221479509939dad488a4c375c8660c3b3cf424b538c887f8874ba3e63d5edeff5044e0725082a1d98d284b46d9c608b694188b6581
-MISC metadata.xml 233 BLAKE2B 2b385ca77219f08b2874b3a4a91a0c836d3cb45ec44b05babb33d590c56ceb5337ecb93a8450a37f8e6bbf4cfc1455892e8142d22e0a1d527d40361e2dce350b SHA512 1acc975a7dc3344bc63282d652ca00d8245970b58353b4fd00f09a4859db3eaba2dcd85e1537d424b7174e4f9c01c2ffb10ec6d107b5c895c9ca20730666de7f
diff --git a/dev-java/colt/colt-1.2.0-r3.ebuild b/dev-java/colt/colt-1.2.0-r3.ebuild
deleted file mode 100644
index 24cb77f19188..000000000000
--- a/dev-java/colt/colt-1.2.0-r3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-JAVA_PKG_IUSE="source doc"
-
-inherit java-pkg-2 java-ant-2 epatch
-
-DESCRIPTION="Java Libraries for High Performance Scientific and Technical Computing"
-SRC_URI="http://dsd.lbl.gov/~hoschek/colt-download/releases/${P}.tar.gz"
-HOMEPAGE="http://www-itg.lbl.gov/~hoschek/colt/"
-
-LICENSE="colt"
-IUSE=""
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-
-DEPEND=">=virtual/jdk-1.7"
-RDEPEND=">=virtual/jre-1.7"
-
-S="${WORKDIR}/${PN}"
-
-EANT_BUILD_TARGET="javac jar"
-JAVA_ANT_ENCODING="ISO-8859-1"
-
-# [0]: I don't know but it must be useful.
-# [1]: Monkey patch manually some classes to get rid of the
-# oswego.edu.concurrent.util imports.
-PATCHES=(
- "${FILESDIR}/${P}-benchmark-no-deprecation.patch"
- "${FILESDIR}/${P}-remove-concurrent-util-imports.patch"
-)
-
-java_prepare() {
- epatch "${PATCHES[@]}"
- java-pkg_clean
-}
-
-src_install() {
- java-pkg_dojar "lib/${PN}.jar"
-
- dohtml README.html
- use doc && java-pkg_dojavadoc doc/api
- use source && java-pkg_dosrc src/*
-}
diff --git a/dev-java/colt/files/colt-1.2.0-benchmark-no-deprecation.patch b/dev-java/colt/files/colt-1.2.0-benchmark-no-deprecation.patch
deleted file mode 100644
index 2617dc49ad57..000000000000
--- a/dev-java/colt/files/colt-1.2.0-benchmark-no-deprecation.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- src/cern/colt/matrix/impl/BenchmarkMatrix2D.java 2005-12-13 00:57:28.000000000 -0600
-+++ src/cern/colt/matrix/impl/BenchmarkMatrix2D.java 2005-12-13 01:20:09.000000000 -0600
-@@ -331,6 +331,8 @@
- cern.colt.Timer timer1 = new cern.colt.Timer();
- cern.colt.Timer timer2 = new cern.colt.Timer();
-
-+ cern.jet.math.Functions F = cern.jet.math.Functions.functions;
-+
- long size = (((long)rows)*columns)*runs;
-
- DoubleMatrix2D matrix = null;
-@@ -344,7 +346,8 @@
- //if (kind.equals("sparse")) ((SparseDoubleMatrix2D)matrix).elements.hashCollisions = 0;
- for (int i=0; i<runs; i++) {
- timer1.start();
-- cern.colt.matrix.doublealgo.Transform.mult(matrix, 3);
-+ //cern.colt.matrix.doublealgo.Transform.mult(matrix, 3);
-+ matrix.assign(F.mult(3));
- timer1.stop();
- }
- timer1.display();
-@@ -366,7 +369,8 @@
- //if (kind.equals("sparse")) ((SparseDoubleMatrix2D)matrix).elements.hashCollisions = 0;
- for (int i=0; i<runs; i++) {
- timer2.start();
-- cern.colt.matrix.doublealgo.Transform.mult(matrix,3);
-+ // cern.colt.matrix.doublealgo.Transform.mult(matrix,3);
-+ matrix.assign(F.mult(3));
- timer2.stop();
- }
- timer2.display();
diff --git a/dev-java/colt/files/colt-1.2.0-remove-concurrent-util-imports.patch b/dev-java/colt/files/colt-1.2.0-remove-concurrent-util-imports.patch
deleted file mode 100644
index 2cfbef761baf..000000000000
--- a/dev-java/colt/files/colt-1.2.0-remove-concurrent-util-imports.patch
+++ /dev/null
@@ -1,210 +0,0 @@
---- src/cern/colt/matrix/linalg/SmpBlas.java.orig 2015-10-07 22:23:44.969486000 +0000
-+++ src/cern/colt/matrix/linalg/SmpBlas.java 2015-10-07 22:29:15.475486000 +0000
-@@ -10,7 +10,8 @@
-
- import cern.colt.matrix.DoubleMatrix1D;
- import cern.colt.matrix.DoubleMatrix2D;
--import EDU.oswego.cs.dl.util.concurrent.FJTask;
-+
-+import java.util.concurrent.ForkJoinTask;
- /**
- Parallel implementation of the Basic Linear Algebra System for symmetric multi processing boxes.
- Currently only a few algorithms are parallelised; the others are fully functional, but run in sequential mode.
-@@ -198,7 +199,7 @@
-
- // set up concurrent tasks
- int span = width/noOfTasks;
-- final FJTask[] subTasks = new FJTask[noOfTasks];
-+ final ForkJoinTask[] subTasks = new ForkJoinTask[noOfTasks];
- for (int i=0; i<noOfTasks; i++) {
- final int offset = i*span;
- if (i==noOfTasks-1) span = width - span*i; // last span may be a bit larger
-@@ -217,24 +218,30 @@
- CC = C.viewPart(offset,0,span,p);
- }
-
-- subTasks[i] = new FJTask() {
-+ subTasks[i] = new ForkJoinTask() {
- public void run() {
- seqBlas.dgemm(transposeA,transposeB,alpha,AA,BB,beta,CC);
- //System.out.println("Hello "+offset);
- }
-+
-+ public boolean exec() { return true; }
-+ public void setRawResult(Object o) {}
-+ public Object getRawResult() {return null;}
- };
- }
-
- // run tasks and wait for completion
-- try {
-- this.smp.taskGroup.invoke(
-- new FJTask() {
-- public void run() {
-- coInvoke(subTasks);
-- }
-- }
-- );
-- } catch (InterruptedException exc) {}
-+ this.smp.taskGroup.invoke(
-+ new ForkJoinTask() {
-+ public void run() {
-+ invokeAll(subTasks);
-+ }
-+
-+ public boolean exec() { return true; }
-+ public void setRawResult(Object o) {}
-+ public Object getRawResult() {return null;}
-+ }
-+ );
- }
- public void dgemv(final boolean transposeA, final double alpha, DoubleMatrix2D A, final DoubleMatrix1D x, final double beta, DoubleMatrix1D y) {
- /*
-@@ -271,7 +278,7 @@
-
- // set up concurrent tasks
- int span = width/noOfTasks;
-- final FJTask[] subTasks = new FJTask[noOfTasks];
-+ final ForkJoinTask[] subTasks = new ForkJoinTask[noOfTasks];
- for (int i=0; i<noOfTasks; i++) {
- final int offset = i*span;
- if (i==noOfTasks-1) span = width - span*i; // last span may be a bit larger
-@@ -280,24 +287,30 @@
- final DoubleMatrix2D AA = A.viewPart(offset,0,span,n);
- final DoubleMatrix1D yy = y.viewPart(offset,span);
-
-- subTasks[i] = new FJTask() {
-+ subTasks[i] = new ForkJoinTask() {
- public void run() {
- seqBlas.dgemv(transposeA,alpha,AA,x,beta,yy);
- //System.out.println("Hello "+offset);
- }
-+
-+ public boolean exec() { return true; }
-+ public void setRawResult(Object o) {}
-+ public Object getRawResult() {return null;}
- };
- }
-
- // run tasks and wait for completion
-- try {
-- this.smp.taskGroup.invoke(
-- new FJTask() {
-- public void run() {
-- coInvoke(subTasks);
-- }
-- }
-- );
-- } catch (InterruptedException exc) {}
-+ this.smp.taskGroup.invoke(
-+ new ForkJoinTask() {
-+ public void run() {
-+ invokeAll(subTasks);
-+ }
-+
-+ public boolean exec() { return true; }
-+ public void setRawResult(Object o) {}
-+ public Object getRawResult() {return null;}
-+ }
-+ );
- }
- public void dger(double alpha, DoubleMatrix1D x, DoubleMatrix1D y, DoubleMatrix2D A) {
- seqBlas.dger(alpha,x,y,A);
-@@ -369,9 +382,6 @@
- /**
- * Prints various snapshot statistics to System.out; Simply delegates to {@link EDU.oswego.cs.dl.util.concurrent.FJTaskRunnerGroup#stats}.
- */
--public void stats() {
-- if (this.smp!=null) this.smp.stats();
--}
- private double xsum(DoubleMatrix2D A) {
- double[] sums = run(A,true,
- new Matrix2DMatrix2DFunction() {
---- src/cern/colt/matrix/linalg/Smp.java.orig 2015-10-07 21:08:19.443486000 +0000
-+++ src/cern/colt/matrix/linalg/Smp.java 2015-10-07 22:28:24.722486000 +0000
-@@ -9,12 +9,13 @@
- package cern.colt.matrix.linalg;
-
- import cern.colt.matrix.DoubleMatrix2D;
--import EDU.oswego.cs.dl.util.concurrent.FJTask;
--import EDU.oswego.cs.dl.util.concurrent.FJTaskRunnerGroup;
-+import java.util.concurrent.ForkJoinTask;
-+import java.util.concurrent.ForkJoinPool;
-+
- /*
- */
- class Smp {
-- protected FJTaskRunnerGroup taskGroup; // a very efficient and light weight thread pool
-+ protected ForkJoinPool taskGroup; // a very efficient and light weight thread pool
-
- protected int maxThreads;
- /**
-@@ -24,41 +25,39 @@
- maxThreads = Math.max(1,maxThreads);
- this.maxThreads = maxThreads;
- if (maxThreads>1) {
-- this.taskGroup = new FJTaskRunnerGroup(maxThreads);
-+ this.taskGroup = new ForkJoinPool(maxThreads);
- }
- else { // avoid parallel overhead
- this.taskGroup = null;
- }
- }
--/**
-- * Clean up deamon threads, if necessary.
-- */
--public void finalize() {
-- if (this.taskGroup!=null) this.taskGroup.interruptAll();
--}
- protected void run(final DoubleMatrix2D[] blocksA, final DoubleMatrix2D[] blocksB, final double[] results, final Matrix2DMatrix2DFunction function) {
-- final FJTask[] subTasks = new FJTask[blocksA.length];
-+ final ForkJoinTask[] subTasks = new ForkJoinTask[blocksA.length];
- for (int i=0; i<blocksA.length; i++) {
- final int k = i;
-- subTasks[i] = new FJTask() {
-+ subTasks[i] = new ForkJoinTask() {
- public void run() {
- double result = function.apply(blocksA[k],blocksB != null ? blocksB[k] : null);
- if (results!=null) results[k] = result;
- //System.out.print(".");
- }
-+ public boolean exec() { return true; }
-+ public void setRawResult(Object o) {}
-+ public Object getRawResult() {return null;}
- };
- }
-
- // run tasks and wait for completion
-- try {
-- this.taskGroup.invoke(
-- new FJTask() {
-- public void run() {
-- coInvoke(subTasks);
-- }
-- }
-- );
-- } catch (InterruptedException exc) {}
-+ this.taskGroup.invoke(
-+ new ForkJoinTask() {
-+ public void run() {
-+ invokeAll(subTasks);
-+ }
-+ public boolean exec() { return true; }
-+ public void setRawResult(Object o) {}
-+ public Object getRawResult() {return null;}
-+ }
-+ );
- }
- protected DoubleMatrix2D[] splitBlockedNN(DoubleMatrix2D A, int threshold, long flops) {
- /*
-@@ -186,10 +185,4 @@
- }
- return blocks;
- }
--/**
-- * Prints various snapshot statistics to System.out; Simply delegates to {@link EDU.oswego.cs.dl.util.concurrent.FJTaskRunnerGroup#stats}.
-- */
--public void stats() {
-- if (this.taskGroup!=null) this.taskGroup.stats();
--}
- }
diff --git a/dev-java/colt/metadata.xml b/dev-java/colt/metadata.xml
deleted file mode 100644
index 6021501589e0..000000000000
--- a/dev-java/colt/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
-</maintainer>
-</pkgmetadata>