summaryrefslogtreecommitdiff
path: root/dev-java/error-prone-annotations/error-prone-annotations-2.0.14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/error-prone-annotations/error-prone-annotations-2.0.14.ebuild')
-rw-r--r--dev-java/error-prone-annotations/error-prone-annotations-2.0.14.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/error-prone-annotations/error-prone-annotations-2.0.14.ebuild b/dev-java/error-prone-annotations/error-prone-annotations-2.0.14.ebuild
new file mode 100644
index 000000000000..bde172d25913
--- /dev/null
+++ b/dev-java/error-prone-annotations/error-prone-annotations-2.0.14.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN%-annotations}"
+MY_P="${MY_PN}-${PV}"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java annotations for the Error Prone static analysis tool"
+HOMEPAGE="http://errorprone.info"
+SRC_URI="https://github.com/google/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/${MY_P}/annotations"
+JAVA_SRC_DIR="src/main/java"