summaryrefslogtreecommitdiff
path: root/dev-java/freehep-io/freehep-io-2.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/freehep-io/freehep-io-2.2.2.ebuild')
-rw-r--r--dev-java/freehep-io/freehep-io-2.2.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/freehep-io/freehep-io-2.2.2.ebuild b/dev-java/freehep-io/freehep-io-2.2.2.ebuild
new file mode 100644
index 000000000000..1343d8707ff8
--- /dev/null
+++ b/dev-java/freehep-io/freehep-io-2.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="High Energy Physics Java library - FreeHEP I/O Library"
+HOMEPAGE="http://java.freehep.org/"
+SRC_URI="https://github.com/freehep/${PN}/archive/${P}.tar.gz"
+LICENSE="Apache-2.0 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.7
+ test? ( dev-java/junit:4 )"
+
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/${PN}-${P}"
+JAVA_SRC_DIR="src/main/java"
+
+src_test() {
+ local DIR=src/test/java
+ local CP="${DIR}:${PN}.jar:$(java-pkg_getjars junit-4)"
+ local TESTS=$(find ${DIR} -name "*Test.java" ! -name "Abstract*")
+ TESTS="${TESTS//src\/test\/java\/}"
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d ${DIR} $(find ${DIR} -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}