summaryrefslogtreecommitdiff
path: root/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.80.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/java-sdk-docs/java-sdk-docs-1.7.0.80.ebuild')
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.7.0.80.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.80.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.80.ebuild
deleted file mode 100644
index 42915862de63..000000000000
--- a/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.80.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit versionator
-
-MY_PV="$(get_version_component_range 2)u$(get_version_component_range 4)"
-
-DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/java-se-7-doc-download-435117.html#jdk-${MY_PV}-apidocs-oth-JPR"
-ORIG_NAME="jdk-${MY_PV}-docs-all.zip"
-
-DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
-HOMEPAGE="http://download.oracle.com/javase/7/docs/"
-SRC_URI="${ORIG_NAME}"
-
-LICENSE="oracle-java-documentation-7"
-SLOT="1.7"
-KEYWORDS="amd64 ~arm ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-
-RESTRICT="fetch"
-
-S="${WORKDIR}/docs"
-
-pkg_nofetch() {
- einfo "Please download ${ORIG_NAME} from "
- einfo "${DOWNLOAD_URL}"
- einfo "(agree to the license) and place it in ${DISTDIR}"
-
- einfo "If you find the file on the download page replaced with a higher"
- einfo "version, please report to the bug 67266 (link below)."
- einfo "If emerge fails because of a checksum error it is possible that"
- einfo "the upstream release changed without renaming. Try downloading the file"
- einfo "again (or a newer revision if available). Otherwise report this to"
- einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
-}
-
-src_install(){
- insinto /usr/share/doc/${P}/html
- doins index.html
-
- for i in *; do
- [[ -d $i ]] && doins -r $i
- done
-}