summaryrefslogtreecommitdiff
path: root/dev-java/jchart2d/jchart2d-3.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jchart2d/jchart2d-3.2.2.ebuild')
-rw-r--r--dev-java/jchart2d/jchart2d-3.2.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/jchart2d/jchart2d-3.2.2.ebuild b/dev-java/jchart2d/jchart2d-3.2.2.ebuild
new file mode 100644
index 000000000000..4e3f1e632d16
--- /dev/null
+++ b/dev-java/jchart2d/jchart2d-3.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A minimalistic realtime charting library for Java"
+HOMEPAGE="http://jchart2d.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/sources/${PN}-eclipse-project-${PV}.zip"
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # Even the headless tests need a display!?
+
+CDEPEND="dev-java/jide-oss:0
+ dev-java/xmlgraphics-commons:2"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="jide-oss,xmlgraphics-commons-2"
+JAVA_SRC_DIR="src"
+
+S="${WORKDIR}/${PN}"
+
+java_prepare() {
+ rm -rv ext/* || die
+
+ # Ant tries and fails to build these outdated bug
+ # demonstrations. Did Ant's globbing behaviour change?
+ rm -v src/*.java || die
+}