summaryrefslogtreecommitdiff
path: root/dev-java/okio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/okio')
-rw-r--r--dev-java/okio/Manifest4
-rw-r--r--dev-java/okio/files/okio-remove-maven-animal-jre.patch44
-rw-r--r--dev-java/okio/metadata.xml11
-rw-r--r--dev-java/okio/okio-1.11.0.ebuild39
4 files changed, 0 insertions, 98 deletions
diff --git a/dev-java/okio/Manifest b/dev-java/okio/Manifest
deleted file mode 100644
index c9282b82e011..000000000000
--- a/dev-java/okio/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX okio-remove-maven-animal-jre.patch 1631 BLAKE2B e43c497a63d598ceb825716de40a6f1869e39a45eccbb4759c128805bfcf52a5b95658bb776299a32e7ef2970dc6466dcfb5d422032c460675d416ec2412fc09 SHA512 5bd6cacf2ca9cf51ee7b80fc5deead8174fb579dc3a8422f65b7af80492f37d24ccad4605896f0653984852db89c2ca9ce0b78bd0ea2630ad8c71e1808b9a3f7
-DIST okio-1.11.0.zip 147483 BLAKE2B 776b77f12d72eafd573793b3a7e146d042cd07c38bdc96dd549ce82018cf128e40aee0a19bf019ffd174d73e75b35508c96684d87f443e4fb28da2964276eb4d SHA512 c8f440284d683a04e3d75d6f6715e229c06caad5e7f2bc544348703cdfbd8fe5bfb19f0c316ea4cfb473a933b03bda2277de8c0b7c956b143cc04826e61cf0b6
-EBUILD okio-1.11.0.ebuild 754 BLAKE2B 91748fc321cbac3b333bb7f39b07ca74e5f1a850e723256aa4f686909e99b4ab6d01a5ff812da3892d622bfa6052947a10ba8c5c182c3d8a63abf3337131e2d9 SHA512 405fb52d98b0b3b044d1e92ce3c6cca8654ea1816b6149a4b9bfe9a76943994e6f8d3975e985127cbf76395bf59acd3297ed5d1217c198d1fcdfd08b4ce01544
-MISC metadata.xml 312 BLAKE2B 4d749d9fd3b69a6e7cd51d9c1c9fbca98d6d6363147f0ee55ff767a3a8880d53cb0f4ab41fb8338e2c2d5aa3234b28fa61608d2332fcf9e1491e9f411c6d6a25 SHA512 595713b72b25fddd2950c667f082fef0ce861354c44a878efcaf721abdb8761c2496a9b975c21824cfebdea6d9d4fc39560c2f8747a868ccbf08b49ff7dbbb25
diff --git a/dev-java/okio/files/okio-remove-maven-animal-jre.patch b/dev-java/okio/files/okio-remove-maven-animal-jre.patch
deleted file mode 100644
index 0e5e5d62880e..000000000000
--- a/dev-java/okio/files/okio-remove-maven-animal-jre.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- okio/src/main/java/okio/DeflaterSink.java 2016-08-22 12:01:19.828823222 -0500
-+++ okio/src/main/java/okio/DeflaterSink.java 2016-08-22 12:01:25.039823574 -0500
-@@ -17,7 +17,6 @@
-
- import java.io.IOException;
- import java.util.zip.Deflater;
--import org.codehaus.mojo.animal_sniffer.IgnoreJRERequirement;
-
- import static okio.Util.checkOffsetAndCount;
-
-@@ -79,7 +78,6 @@
- }
- }
-
-- @IgnoreJRERequirement
- private void deflate(boolean syncFlush) throws IOException {
- Buffer buffer = sink.buffer();
- while (true) {
---- okio/src/main/java/okio/Okio.java 2016-08-22 12:03:23.819831591 -0500
-+++ okio/src/main/java/okio/Okio.java 2016-08-22 12:03:34.874832337 -0500
-@@ -30,7 +30,6 @@
- import java.nio.file.Path;
- import java.util.logging.Level;
- import java.util.logging.Logger;
--import org.codehaus.mojo.animal_sniffer.IgnoreJRERequirement;
-
- import static okio.Util.checkOffsetAndCount;
-
-@@ -167,7 +166,6 @@
- }
-
- /** Returns a source that reads from {@code path}. */
-- @IgnoreJRERequirement // Should only be invoked on Java 7+.
- public static Source source(Path path, OpenOption... options) throws IOException {
- if (path == null) throw new IllegalArgumentException("path == null");
- return source(Files.newInputStream(path, options));
-@@ -186,7 +184,6 @@
- }
-
- /** Returns a sink that writes to {@code path}. */
-- @IgnoreJRERequirement // Should only be invoked on Java 7+.
- public static Sink sink(Path path, OpenOption... options) throws IOException {
- if (path == null) throw new IllegalArgumentException("path == null");
- return sink(Files.newOutputStream(path, options));
diff --git a/dev-java/okio/metadata.xml b/dev-java/okio/metadata.xml
deleted file mode 100644
index 1f3df0522d64..000000000000
--- a/dev-java/okio/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
- <upstream>
- <remote-id type="github">square/okio</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-java/okio/okio-1.11.0.ebuild b/dev-java/okio/okio-1.11.0.ebuild
deleted file mode 100644
index 57105c8e9838..000000000000
--- a/dev-java/okio/okio-1.11.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-MY_P="${PN}-parent-${PV}"
-
-DESCRIPTION="A modern I/O API for Java"
-HOMEPAGE="https://github.com/square/okio"
-SRC_URI="https://github.com/square/${PN}/archive/${MY_P}.zip -> ${P}.zip"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=virtual/jre-1.7"
-
-CDEPEND="
- source? ( app-arch/zip )
- dev-java/jmh-core:0
- dev-java/junit:4"
-
-DEPEND=">=virtual/jdk-1.7
- ${CDEPEND}"
-
-RDEPEND=">=virtual/jre-1.7
- ${CDEPEND}"
-
-S="${WORKDIR}/${PN}-${MY_P}"
-
-JAVA_GENTOO_CLASSPATH="jmh-core,junit-4"
-
-src_prepare(){
- epatch "${FILESDIR}/okio-remove-maven-animal-jre.patch"
-}