summaryrefslogtreecommitdiff
path: root/dev-java/stax2-api/stax2-api-4.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/stax2-api/stax2-api-4.2.1.ebuild')
-rw-r--r--dev-java/stax2-api/stax2-api-4.2.1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-java/stax2-api/stax2-api-4.2.1.ebuild b/dev-java/stax2-api/stax2-api-4.2.1.ebuild
deleted file mode 100644
index e0db485cf34e..000000000000
--- a/dev-java/stax2-api/stax2-api-4.2.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/FasterXML/stax2-api/archive/refs/tags/stax2-api-4.2.1.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild stax2-api-4.2.1.ebuild
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source"
-MAVEN_ID="org.codehaus.woodstox:stax2-api:4.2.1"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="stax2 API is an extension to basic Stax 1.0 API"
-HOMEPAGE="https://github.com/FasterXML/stax2-api"
-SRC_URI="https://github.com/FasterXML/${PN}/archive/refs/tags/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-DEPEND=">=virtual/jdk-1.8:*"
-RDEPEND=">=virtual/jre-1.8:*"
-
-DOCS=( README.md release-notes/VERSION )
-
-S="${WORKDIR}/${PN}-${P}"
-
-JAVA_SRC_DIR=( "src/main/java" "src/moditect" )
-JAVA_RESOURCE_DIRS="src/main/resources"
-
-src_install() {
- default # https://bugs.gentoo.org/789582
- java-pkg-simple_src_install
-}