summaryrefslogtreecommitdiff
path: root/dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1-r1.ebuild')
-rw-r--r--dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1-r1.ebuild b/dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..f4d927f6dc62
--- /dev/null
+++ b/dev-java/sun-httpserver-bin/sun-httpserver-bin-2.0.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit java-pkg-2
+
+DESCRIPTION="Sun sun.net.httpserver classes"
+HOMEPAGE="http://jax-ws.dev.java.net/"
+DATE="20060817"
+MY_P="JAXWS${PV}m1_source_${DATE}.jar"
+SRC_URI="https://jax-ws.dev.java.net/jax-ws-201-m1/${MY_P}"
+
+LICENSE="CDDL"
+SLOT="2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+S="${WORKDIR}/jaxws-si"
+
+src_unpack() {
+ MY_JAVA=$(java-config -J)
+
+ echo "A" | ${MY_JAVA} -jar "${DISTDIR}/${A}" -console > /dev/null || die "unpack failed"
+
+ unpack ./jaxws-src.zip || die "unzip failed"
+
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ java-pkg_dojar lib/http.jar
+}