summaryrefslogtreecommitdiff
path: root/dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22-r1.ebuild')
-rw-r--r--dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22-r1.ebuild b/dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22-r1.ebuild
new file mode 100644
index 000000000000..252ec5063ff4
--- /dev/null
+++ b/dev-java/touchgraph-graphlayout/touchgraph-graphlayout-1.22-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="TGGraphLayout"
+
+DESCRIPTION="TouchGraph provides a set of interfaces for graph visualization"
+HOMEPAGE="http://touchgraph.sourceforge.net"
+SRC_URI="mirror://sourceforge/touchgraph/TGGL_${PV//./}_jre11.zip"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/${MY_PN}"
+
+JAVA_SRC_DIR="com"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc "TGGL ReleaseNotes.txt"
+}