summaryrefslogtreecommitdiff
path: root/dev-lang/haxe
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/haxe')
-rw-r--r--dev-lang/haxe/Manifest3
-rw-r--r--dev-lang/haxe/haxe-4.2.4-r2.ebuild73
-rw-r--r--dev-lang/haxe/metadata.xml19
3 files changed, 95 insertions, 0 deletions
diff --git a/dev-lang/haxe/Manifest b/dev-lang/haxe/Manifest
new file mode 100644
index 000000000000..d09adf7760fe
--- /dev/null
+++ b/dev-lang/haxe/Manifest
@@ -0,0 +1,3 @@
+DIST haxe-4.2.4.tar.gz 9151011 BLAKE2B 76e4442dbd33669abb2defcb66a781bf013ac41a4853f7911824e16816c60fff7e46bd58b9f2830194326aadbd79b2f07ab14308efdb0ef1e26177178daf3941 SHA512 c447b2fa7e7b7149a87af2dd75e08cce1b8d96238b88024d875659add62fa97d554ecd7f13200b817545eda8be00d61399551d64f7dbc9cc1aa66a5517dd2485
+EBUILD haxe-4.2.4-r2.ebuild 1394 BLAKE2B 41dff99e7fc9773404bca0955cc8324c50126cacb55cb1febcb85bce9781e0f988fbddbc7f6c5eacdf6c3e2e9023952d79426f7d840508058a36466c94e3a3cc SHA512 9fa7a34434fb775778b5bd9fbedc0a1f6a24672b78140bd19469f49cd3d4f7ff1db90cb412a1a6bda340eea77722c6c904a672a782f8c9c978cdc6eb5aff2338
+MISC metadata.xml 732 BLAKE2B 52f1d6cded6290eb442a11cdfe3d4b987fa15e2f41ab641a0ec52e6925128e57ccdc0f31261a5cb1294a9cee1b06a49ac6ad05402c65d174b39e498cfc2c6431 SHA512 b05010f6a9aa433006e6e523df56f84d7db456fc88b34884899f08873b2c1f93176eb70747429698303d3a1d3493f277c42efd7eee6a9c44f4c225bde2d76238
diff --git a/dev-lang/haxe/haxe-4.2.4-r2.ebuild b/dev-lang/haxe/haxe-4.2.4-r2.ebuild
new file mode 100644
index 000000000000..6a8441c77ab2
--- /dev/null
+++ b/dev-lang/haxe/haxe-4.2.4-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Multi-target universal programming language"
+HOMEPAGE="https://haxe.org/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/HaxeFoundation/haxe.git"
+else
+ # Haxe-debian already contains correct git modules
+ SRC_URI="https://github.com/HaxeFoundation/haxe-debian/archive/upstream/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/haxe-debian-upstream-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt"
+
+# NOTICE:
+# Theoretically luv <= 0.5.8 is pinned but it is because of mingw issues
+RDEPEND="
+ >=dev-lang/ocaml-4:=[ocamlopt?]
+ dev-ml/extlib:=
+ dev-ml/luv:=
+ dev-ml/ocaml-sha:=
+ dev-ml/ptmap:=
+ dev-ml/sedlex:=
+ dev-ml/xml-light:=
+
+ dev-lang/neko:=
+ dev-libs/boehm-gc:=
+ dev-libs/libpcre:=
+ net-libs/mbedtls:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/camlp5
+ dev-ml/dune
+ dev-ml/findlib
+"
+
+QA_FLAGS_IGNORED="usr/bin/haxelib"
+QA_PRESTRIPPED="usr/bin/haxelib"
+
+src_configure() {
+ if use ocamlopt ; then
+ export OCAMLOPT=ocamlopt.opt
+ else
+ export OCAMLOPT=ocamlopt
+ fi
+}
+
+src_compile() {
+ local mymakeargs=(
+ BRANCH=""
+ COMMIT_DATE=""
+ COMMIT_SHA=""
+ OCAMLOPT=${OCAMLOPT}
+ INSTALL_DIR=/usr
+ )
+ emake -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_DIR=/usr install
+
+ dodoc *.md
+}
diff --git a/dev-lang/haxe/metadata.xml b/dev-lang/haxe/metadata.xml
new file mode 100644
index 000000000000..bb58a6128b6f
--- /dev/null
+++ b/dev-lang/haxe/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ Haxe is an open source toolkit based on a modern, high level, static-typed
+ programming language, a cross-compiler, a complete cross-platform standard
+ library and ways to access each platform's native capabilities.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/HaxeFoundation/haxe/issues/</bugs-to>
+ <remote-id type="github">HaxeFoundation/haxe-debian</remote-id>
+ <remote-id type="github">HaxeFoundation/haxe</remote-id>
+ </upstream>
+</pkgmetadata>