summaryrefslogtreecommitdiff
path: root/dev-lang/kotlin-bin
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/kotlin-bin')
-rw-r--r--dev-lang/kotlin-bin/Manifest2
-rw-r--r--dev-lang/kotlin-bin/kotlin-bin-2.1.10.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-lang/kotlin-bin/Manifest b/dev-lang/kotlin-bin/Manifest
index fac531d53fad..7c2958622203 100644
--- a/dev-lang/kotlin-bin/Manifest
+++ b/dev-lang/kotlin-bin/Manifest
@@ -1,5 +1,7 @@
DIST kotlin-compiler-2.0.21.zip 85822011 BLAKE2B 007a3cb8902e5a12d883ede2ef670f821471c3273dc97d17935006e0dc35989fe540cbeaa0a8203fc95e05f2b36d95000a1e3ac11803c2723b1dfa361a102470 SHA512 0ab48b49fc3582274485eb5c65a6e5b5de9c45e9c2faafb0720bf07308af50d813eae6d73c57a56daed6b9fd5378d40ce701f14f13e3063bdb38c5d529eb7626
DIST kotlin-compiler-2.1.0.zip 86409360 BLAKE2B 67fbdf3e074f44bfe7ee788b458d9ac9a2e0c4d471c312fd3e050df3e9a659994b5884b5d964603ee6b16e1e4f347b4e645245ce0aeb97beeacb250ba8ed83f7 SHA512 1c14213fc10543af09bc031274be7ef9b3cf1b5d0629de3fde731578e2d84d002ab9b3df90c0417d34eaabff7ea9501209e9323662a6c4eb5504f34fcb10c7f0
+DIST kotlin-compiler-2.1.10.zip 86422666 BLAKE2B f93c1af67eb82ea493fae917c74f4800d4616f246454532dfa98ae8486f97d9471c54e7e2c703c23482e9c52c5435e0bc2cba5f28e18c8801fd0980a06ef32f5 SHA512 283b4a85f729c13af9c168799fa49bd9f9d190109da53e48284662844a2aad40c3a5a7716366ddc82c8c382901756e148265c340c8fcf0ab7b74f2df23e19b0e
EBUILD kotlin-bin-2.0.21.ebuild 1005 BLAKE2B 0c2efbc96602feaa82e87463c19ab244d44bd7b9596177346ae08331d37a53e1f033f41cc0ee557e7b806997a1d553b8e33eb8abd69bd8552db316053276d21f SHA512 c96c829a4c8f21ed7a82de4af30756806d27f72394242115a1cc34fa755f93f1d1cd7a42abfc6bb40ab3c4209ea6428464ccc9a32aadb16e077f132194abb085
EBUILD kotlin-bin-2.1.0.ebuild 1005 BLAKE2B 0c2efbc96602feaa82e87463c19ab244d44bd7b9596177346ae08331d37a53e1f033f41cc0ee557e7b806997a1d553b8e33eb8abd69bd8552db316053276d21f SHA512 c96c829a4c8f21ed7a82de4af30756806d27f72394242115a1cc34fa755f93f1d1cd7a42abfc6bb40ab3c4209ea6428464ccc9a32aadb16e077f132194abb085
+EBUILD kotlin-bin-2.1.10.ebuild 1005 BLAKE2B add055e3ec1d41995fad1c054080a5942be531e71585352ee5ccdc18ff20386c8b73a14e3162cdb1a794a8f8df194804dbff8f21900cead6772da17f4c8b71a0 SHA512 600c2cf2dc3814ba03fcecd7ccae7b9b71bedcf47045ce5d39a6612593c6f830b6a89229e46f77957a285a77c70c28fedc2bae14736efc77aabb14b274903208
MISC metadata.xml 696 BLAKE2B 5ff5c3681ab7e083f1a2ea607b183c279c50a022eea2237bfc705d67b8e3ddac7d61fdb1774ac2d6214e03d61d0fb03367cd399734a4b537dcf53a3d8cb14de1 SHA512 44186263fa0709e3d4fadd54cc80e1063d215f908855be9476062259387ec9d968f35bfe8da6fbc716be22a53212630676157fd08fbebd67c20dc4a4485b5a44
diff --git a/dev-lang/kotlin-bin/kotlin-bin-2.1.10.ebuild b/dev-lang/kotlin-bin/kotlin-bin-2.1.10.ebuild
new file mode 100644
index 000000000000..5efa76704267
--- /dev/null
+++ b/dev-lang/kotlin-bin/kotlin-bin-2.1.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2 wrapper
+
+DESCRIPTION="Statically typed language that targets the JVM and JavaScript"
+HOMEPAGE="https://kotlinlang.org/
+ https://github.com/JetBrains/kotlin/"
+SRC_URI="https://github.com/JetBrains/kotlin/releases/download/v${PV}/kotlin-compiler-${PV}.zip"
+S="${WORKDIR}/kotlinc"
+
+LICENSE="Apache-2.0 BSD MIT NPL-1.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+src_prepare() {
+ default
+
+ rm bin/*.bat || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ java-pkg_dojar lib/*
+
+ # Follow the Java eclass JAR installation path.
+ local app_home="/usr/share/${PN}"
+
+ exeinto "${app_home}/bin"
+ doexe bin/*
+
+ local -a exes=(
+ kapt
+ kotlin
+ kotlinc
+ kotlinc-js
+ kotlinc-jvm
+ kotlin-dce-js
+ )
+ local exe
+ for exe in "${exes[@]}" ; do
+ make_wrapper "${exe}" "${app_home}/bin/${exe}"
+ done
+}