summaryrefslogtreecommitdiff
path: root/dev-lang/nasm/nasm-2.12.01.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/nasm/nasm-2.12.01.ebuild')
-rw-r--r--dev-lang/nasm/nasm-2.12.01.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-lang/nasm/nasm-2.12.01.ebuild b/dev-lang/nasm/nasm-2.12.01.ebuild
deleted file mode 100644
index 13ef00ee1fa1..000000000000
--- a/dev-lang/nasm/nasm-2.12.01.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit flag-o-matic
-
-DESCRIPTION="groovy little assembler"
-HOMEPAGE="https://www.nasm.us/"
-SRC_URI="https://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc"
-
-DEPEND="dev-lang/perl
- doc? ( app-text/ghostscript-gpl sys-apps/texinfo )"
-RDEPEND=""
-
-S=${WORKDIR}/${P/_}
-
-src_configure() {
- strip-flags
- econf
-}
-
-src_compile() {
- emake nasmlib.o
- emake all
- use doc && emake doc
-}
-
-src_install() {
- emake INSTALLROOT="${D}" install install_rdf
- dodoc AUTHORS CHANGES ChangeLog README TODO
- if use doc ; then
- doinfo doc/info/*
- dohtml doc/html/*
- dodoc doc/nasmdoc.*
- fi
-}