summaryrefslogtreecommitdiff
path: root/dev-lang/perl/perl-5.26.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/perl/perl-5.26.9999.ebuild')
-rw-r--r--dev-lang/perl/perl-5.26.9999.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/dev-lang/perl/perl-5.26.9999.ebuild b/dev-lang/perl/perl-5.26.9999.ebuild
index f1cb393c0f39..2c84ddbd0ed9 100644
--- a/dev-lang/perl/perl-5.26.9999.ebuild
+++ b/dev-lang/perl/perl-5.26.9999.ebuild
@@ -6,17 +6,17 @@ EAPI=6
inherit eutils alternatives flag-o-matic toolchain-funcs multilib multiprocessing
PATCH_VER=1
-CROSS_VER=1.1.7
-PATCH_BASE="perl-5.26.1-patches-${PATCH_VER}"
+CROSS_VER=1.1.9
+PATCH_BASE="perl-5.26.2-patches-${PATCH_VER}"
DIST_AUTHOR=SHAY
# Greatest first, don't include yourself
# Devel point-releases are not ABI-intercompatible, but stable point releases are
# BIN_OLDVERSEN is contains only C-ABI-intercompatible versions
-PERL_BIN_OLDVERSEN="5.26.0"
+PERL_BIN_OLDVERSEN="5.26.1 5.26.0"
if [[ "${PV##*.}" == "9999" ]]; then
- DIST_VERSION=5.26.1-RC1
+ DIST_VERSION=5.26.2
else
DIST_VERSION="${PV/_rc/-RC}"
fi
@@ -83,7 +83,7 @@ dual_scripts() {
src_remove_dual perl-core/ExtUtils-ParseXS 3.340.0 xsubpp
src_remove_dual perl-core/IO-Compress 2.74.0 zipdetails
src_remove_dual perl-core/JSON-PP 2.274.0.200_rc json_pp
- src_remove_dual perl-core/Module-CoreList 5.201.709.220 corelist
+ src_remove_dual perl-core/Module-CoreList 5.201.804.142.600_rc corelist
src_remove_dual perl-core/Pod-Parser 1.630.0 pod2usage podchecker podselect
src_remove_dual perl-core/Pod-Perldoc 3.280.0 perldoc
src_remove_dual perl-core/Test-Harness 3.380.0 prove
@@ -306,6 +306,13 @@ src_prepare_dynamic() {
src_prepare() {
local patch
EPATCH_OPTS+=" -p1"
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # do NOT mess with nsl, on Solaris this is always necessary,
+ # when -lsocket is used e.g. to get h_errno
+ sed -i '/gentoo\/no-nsl\.patch/d' "${WORKDIR}/patches/series" || die "Can't exclude libnsl patch"
+ fi
+
einfo "Applying patches from ${PATCH_BASE} ..."
while read patch ; do
EPATCH_SINGLE_MSG=" ${patch} ..."
@@ -323,6 +330,11 @@ src_prepare() {
ext/NDBM_File/Makefile.PL || die
fi
+ # Use errno.h from prefix rather than from host system, bug #645804
+ if use prefix; then
+ sed -i "/my..sysroot/s:'':'${EPREFIX}':" ext/Errno/Errno_pm.PL || die
+ fi
+
default
}