summaryrefslogtreecommitdiff
path: root/dev-lang/php/php-8.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/php/php-8.3.3.ebuild')
-rw-r--r--dev-lang/php/php-8.3.3.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-lang/php/php-8.3.3.ebuild b/dev-lang/php/php-8.3.3.ebuild
index c914d8167246..488c1dbec923 100644
--- a/dev-lang/php/php-8.3.3.ebuild
+++ b/dev-lang/php/php-8.3.3.ebuild
@@ -151,13 +151,19 @@ PATCHES=(
"${FILESDIR}/php-iodbc-header-location.patch"
)
-# ARM/Windows functions that are expected to be undefined.
+# ARM/Windows functions (bug 923335)
QA_CONFIG_IMPL_DECL_SKIP=(
__crc32d
_controlfp
_controlfp_s
)
+# Functions from alternate iconv implementations (bug 925268)
+QA_CONFIG_IMPL_DECL_SKIP+=(
+ iconv_ccs_init
+ cstoccsid
+)
+
php_install_ini() {
local phpsapi="${1}"