summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-2.7.18_p16-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-2.7.18_p16-r1.ebuild')
-rw-r--r--dev-lang/python/python-2.7.18_p16-r1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-lang/python/python-2.7.18_p16-r1.ebuild b/dev-lang/python/python-2.7.18_p16-r1.ebuild
index 46d496829651..16af9e8af96f 100644
--- a/dev-lang/python/python-2.7.18_p16-r1.ebuild
+++ b/dev-lang/python/python-2.7.18_p16-r1.ebuild
@@ -80,6 +80,8 @@ RDEPEND+="
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/python.org.asc
QA_PKGCONFIG_VERSION=${PYVER}
+# false positives -- functions specific to *BSD
+QA_CONFIG_IMPL_DECL_SKIP=( chflags lchflags )
pkg_setup() {
if use berkdb; then
@@ -187,6 +189,9 @@ src_configure() {
# Python on glibc upgrade, remove it proactively to give
# a chance for users rebuilding python before glibc
ac_cv_header_stropts_h=no
+ # Test program has missing includes. This doesn't change
+ # the result but it's cleaner to force it.
+ ac_cv_broken_poll=no
--with-fpectl
--enable-shared