summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.12.0_alpha7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.12.0_alpha7.ebuild')
-rw-r--r--dev-lang/python/python-3.12.0_alpha7.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.12.0_alpha7.ebuild b/dev-lang/python/python-3.12.0_alpha7.ebuild
index 95d394d31c55..41b53e19a104 100644
--- a/dev-lang/python/python-3.12.0_alpha7.ebuild
+++ b/dev-lang/python/python-3.12.0_alpha7.ebuild
@@ -30,7 +30,7 @@ LICENSE="PSF-2"
SLOT="${PYVER}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="
- bluetooth build +ensurepip examples gdbm hardened libedit lto
+ bluetooth build debug +ensurepip examples gdbm hardened libedit lto
+ncurses pgo +readline +sqlite +ssl test tk valgrind
"
RESTRICT="!test? ( test )"
@@ -215,6 +215,7 @@ src_configure() {
--with-pkg-config=yes
--with-wheel-pkg-dir="${EPREFIX}"/usr/lib/python/ensurepip
+ $(use_with debug assertions)
$(use_with lto)
$(use_enable pgo optimizations)
$(use_with readline readline "$(usex libedit editline readline)")