summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.9.0_alpha4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.9.0_alpha4.ebuild')
-rw-r--r--dev-lang/python/python-3.9.0_alpha4.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.9.0_alpha4.ebuild b/dev-lang/python/python-3.9.0_alpha4.ebuild
index 77a4321ff044..49d4c9d5f877 100644
--- a/dev-lang/python/python-3.9.0_alpha4.ebuild
+++ b/dev-lang/python/python-3.9.0_alpha4.ebuild
@@ -19,7 +19,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="bluetooth build examples gdbm hardened ipv6 libressl +ncurses +readline sqlite +ssl test tk wininst +xml"
RESTRICT="!test? ( test )"
@@ -82,6 +82,7 @@ src_prepare() {
local PATCHES=(
"${WORKDIR}/${PATCHSET}"
+ "${FILESDIR}/test.support.unlink-ignore-PermissionError.patch"
)
default
@@ -149,6 +150,11 @@ src_configure() {
fi
local myeconfargs=(
+ # glibc-2.30 removes it; since we can't cleanly force-rebuild
+ # Python on glibc upgrade, remove it proactively to give
+ # a chance for users rebuilding python before glibc
+ ac_cv_header_stropts_h=no
+
--enable-shared
$(use_enable ipv6)
--infodir='${prefix}/share/info'