summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.9.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.9.9.ebuild')
-rw-r--r--dev-lang/python/python-3.9.9.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-lang/python/python-3.9.9.ebuild b/dev-lang/python/python-3.9.9.ebuild
index b98774878ab2..cd4cc9ae614a 100644
--- a/dev-lang/python/python-3.9.9.ebuild
+++ b/dev-lang/python/python-3.9.9.ebuild
@@ -59,7 +59,7 @@ BDEPEND="
virtual/awk
virtual/pkgconfig
sys-devel/autoconf-archive
- verify-sig? ( app-crypt/openpgp-keys-python )
+ verify-sig? ( sec-keys/openpgp-keys-python )
!sys-devel/gcc[libffi(-)]"
RDEPEND+=" !build? ( app-misc/mime-types )"
@@ -160,7 +160,12 @@ src_configure() {
if use pgo; then
local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
- export PROFILE_TASK="-m test -j${jobs} --pgo-extended -x test_gdb"
+ export PROFILE_TASK="-m test -j${jobs} --pgo-extended -x test_gdb -u-network"
+
+ # All of these seem to occasionally hang for PGO inconsistently
+ # They'll even hang here but be fine in src_test sometimes.
+ # bug #828535 (and related: bug #788022)
+ PROFILE_TASK+=" -x test_socket -x test_asyncio -x test_httpservers -x test_logging -x test_multiprocessing_fork -x test_xmlrpc"
if has_version "app-arch/rpm" ; then
# Avoid sandbox failure (attempts to write to /var/lib/rpm)