summaryrefslogtreecommitdiff
path: root/dev-lang/rust-bin
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust-bin')
-rw-r--r--dev-lang/rust-bin/Manifest2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.81.0.ebuild7
2 files changed, 2 insertions, 7 deletions
diff --git a/dev-lang/rust-bin/Manifest b/dev-lang/rust-bin/Manifest
index 4eff5b916b03..4c905f6764d2 100644
--- a/dev-lang/rust-bin/Manifest
+++ b/dev-lang/rust-bin/Manifest
@@ -245,5 +245,5 @@ EBUILD rust-bin-1.75.0.ebuild 7319 BLAKE2B 6d651ee302620a28e8c9312af50eacb4638b5
EBUILD rust-bin-1.77.1.ebuild 7497 BLAKE2B fb9a25879a8886086486ba5e2010021c01e16ea2c525bf3d36d23e72c7a24eb6f196fd96d3d29231070f5a1db807865e135915224d37eebdffdf485ecc4ca83f SHA512 7ae2fb17a2fcd2d76ae85d1b0420429544a005e2c5ce1cd18a5351353b840d4048d491a316a7a97197198045f4af5f98681b4fa7b5b47df060e0ea6112b3512f
EBUILD rust-bin-1.79.0.ebuild 7604 BLAKE2B 99c532442ff6e40c70a391d777122c32deec8ba8cf45f19d1abdf8e19f75a8776c9741ef54915995e24a646ff94b6e7ed76b2d27ac6631645179109915903d90 SHA512 b64087f5de9753a1476ec0ab72151309e75f4aa847ef0556bff0848a15b473fbb0a535ef1e957d19c92f416ad159d519c97764eb55802fc0c466930002e7e671
EBUILD rust-bin-1.80.1.ebuild 7813 BLAKE2B 188d7efcdd2e6a0b688de4520db2d179f91bd51ff2a8191b44a5d5cb8be12f668a47cff5035c22b3cab7b00f5043f622b2fa0d80bb642aa1403faa10bb362f4b SHA512 8e53e1c781196eca1b2488602b2a3f2c81ff82a7bdd0a09836783c1fa82e4c34f2d073274186eb57683741d8bc69b870bd9921aeee31a29a8717e1350e3d6e03
-EBUILD rust-bin-1.81.0.ebuild 7800 BLAKE2B ed4acb359d0ad776db3396b41fe9d89c0d9cefba1029b29e7e11a5de9309c6b3181b0b55ff2e9097aea6d726b904d0e9c524a4febc2db2723a5e47db0897dc4f SHA512 835b53dfdaaa93d0f5e8b350614780c36b46fccde0c1d29d73624f917677206182781e25b7f1c3e34892b26b9f3edb985e3622302eb3c1d2c611d07dbfbd57ca
+EBUILD rust-bin-1.81.0.ebuild 7596 BLAKE2B fd6b5b27a1497e10c2c41a00378ffbc3550090f94f24e8c39c2622363cda820ad70ebb5ba4973db11223411767dd1a17c3e273f6c93eeb1a6e55aa3a90751bfb SHA512 86364816f170f004b8349758d2fe423d764756ca06bbfc556b467f1f4e61ad3c633b95187f24f1d4cc8d43347903dacef9939c088bf50c265b357b549f507d1d
MISC metadata.xml 1220 BLAKE2B 5c4d286e569c929913317d15d37de08db51655ec41c1d3b1d84aeb6982b53afd7ebf3f9adbcd4e3c76fc9b82056648b6af1507a5728388fd2d2e8d743e5225db SHA512 72d32987894268a7b3ac8e8606428cf8315fcf29ce1945c9e55527a5c696742f6f2a44dcfe01bf5abb0cad60b5881a59dedecdc07db4ef2df22ef13e3b2732a8
diff --git a/dev-lang/rust-bin/rust-bin-1.81.0.ebuild b/dev-lang/rust-bin/rust-bin-1.81.0.ebuild
index e51aa66a54b1..bf78998761f4 100644
--- a/dev-lang/rust-bin/rust-bin-1.81.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.81.0.ebuild
@@ -38,7 +38,7 @@ SRC_URI+=" ppc64? ( elibc_musl? (
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4"
SLOT="stable"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix profiler rust-analyzer rust-src rustfmt"
+IUSE="big-endian clippy cpu_flags_x86_sse2 doc prefix rust-analyzer rust-src rustfmt"
RDEPEND="
>=app-eselect/eselect-rust-20190311
@@ -116,7 +116,6 @@ multilib_src_install() {
local components="rustc,cargo,${std}"
use doc && components="${components},rust-docs"
use clippy && components="${components},clippy-preview"
- use profiler && components="${components},rust-demangler-preview"
use rustfmt && components="${components},rustfmt-preview"
use rust-analyzer && components="${components},rust-analyzer-preview,${analysis}"
# Rust component 'rust-src' is extracted from separate archive
@@ -154,7 +153,6 @@ multilib_src_install() {
)
use clippy && symlinks+=( clippy-driver cargo-clippy )
- use profiler && symlinks+=( rust-demangler )
use rustfmt && symlinks+=( rustfmt cargo-fmt )
use rust-analyzer && symlinks+=( rust-analyzer )
@@ -202,9 +200,6 @@ multilib_src_install() {
echo /usr/bin/clippy-driver >> "${T}/provider-${P}"
echo /usr/bin/cargo-clippy >> "${T}/provider-${P}"
fi
- if use profiler; then
- echo /usr/bin/rust-demangler >> "${T}/provider-${P}"
- fi
if use rustfmt; then
echo /usr/bin/rustfmt >> "${T}/provider-${P}"
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"