summaryrefslogtreecommitdiff
path: root/dev-lang/rust/rust-1.64.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust/rust-1.64.0.ebuild')
-rw-r--r--dev-lang/rust/rust-1.64.0.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-1.64.0.ebuild b/dev-lang/rust/rust-1.64.0.ebuild
index 0300d3cc4b10..9f7e86a87d56 100644
--- a/dev-lang/rust/rust-1.64.0.ebuild
+++ b/dev-lang/rust/rust-1.64.0.ebuild
@@ -163,6 +163,7 @@ VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/rust.asc
PATCHES=(
"${FILESDIR}"/1.55.0-ignore-broken-and-non-applicable-tests.patch
"${FILESDIR}"/1.62.1-musl-dynamic-linking.patch
+ "${FILESDIR}"/${PV}-vendor-rustix-sparc-has-no-SIGSTKFLT.patch
)
S="${WORKDIR}/${MY_P}-src"
@@ -270,6 +271,16 @@ esetup_unwind_hack() {
}
src_prepare() {
+ # this supidity is needed because patch is too large to be in filesdir
+ # and if we move it to devspace - it lacks checksum for sig verification
+ if [[ "${PV}" == 1.64.0 ]]; then
+ sed -i \
+ -e 's/516ba32a547b46a8e80ad20d4a17bf24a00bff0b69b74f56df119f770f3dfff6/fc7eb88c2f5104865379128b76767d36ce5b5fdb9f3483e683d150e514ebc3a3/' \
+ -e 's/fba10dc8ca9eaf4d481cb82bd1540cf5c05620533c44f917c09a22ea55ef408c/9cc4d1b4511a1f0d91231eb0f11c67ae5e8e38e4becd0bf5eb9e26d043796056/' \
+ vendor/rustix/.cargo-checksum.json || die
+ else
+ die "remove sed mr forgetful maintainer"
+ fi
if ! use system-bootstrap; then
has_version sys-devel/gcc || esetup_unwind_hack
local rust_stage0_root="${WORKDIR}"/rust-stage0