summaryrefslogtreecommitdiff
path: root/dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild')
-rw-r--r--dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild b/dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild
index b33495cc06ca..50dc823f254f 100644
--- a/dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild
+++ b/dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="C99 implementation of the vnd.amazon.eventstream content-type"
HOMEPAGE="https://github.com/awslabs/aws-c-event-stream"
@@ -12,8 +12,8 @@ SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
IUSE="test"
+
RESTRICT="!test? ( test )"
DEPEND="
@@ -29,5 +29,5 @@ src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}