summaryrefslogtreecommitdiff
path: root/dev-libs/caliper/caliper-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/caliper/caliper-1.5.0.ebuild')
-rw-r--r--dev-libs/caliper/caliper-1.5.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/caliper/caliper-1.5.0.ebuild b/dev-libs/caliper/caliper-1.5.0.ebuild
new file mode 100644
index 000000000000..8ecd92169088
--- /dev/null
+++ b/dev-libs/caliper/caliper-1.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Application Introspection System"
+HOMEPAGE="http://computation.llnl.gov/projects/caliper"
+SRC_URI="https://github.com/LLNL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ net-misc/curl
+ sys-libs/libunwind
+ dev-libs/papi
+ "
+RDEPEND="${DEPEND}"
+
+#thttps://github.com/LLNL/Caliper/pull/23
+#thttps://github.com/LLNL/Caliper/pull/24
+#thttps://github.com/LLNL/Caliper/pull/25
+PATCHES=( "${FILESDIR}/${P}-cmake.patch"
+ "${FILESDIR}/${P}-python2.patch"
+ "${FILESDIR}/${P}-multilib.patch"
+ )
+
+S="${WORKDIR}/${P^c}"