summaryrefslogtreecommitdiff
path: root/dev-libs/device-atlas-api-c/files/2.1-cmake-install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/device-atlas-api-c/files/2.1-cmake-install.patch')
-rw-r--r--dev-libs/device-atlas-api-c/files/2.1-cmake-install.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/device-atlas-api-c/files/2.1-cmake-install.patch b/dev-libs/device-atlas-api-c/files/2.1-cmake-install.patch
new file mode 100644
index 000000000000..9f518629e5a1
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/files/2.1-cmake-install.patch
@@ -0,0 +1,20 @@
+--- ./CMakeLists.txt 2016-11-08 22:54:33.351677837 +0000
++++ ./CMakeLists.txt 2016-11-08 23:04:26.737184360 +0000
+@@ -16,6 +16,7 @@
+ set(MODEL 64)
+ endif()
+
++include(GNUInstallDirs)
+ message(STATUS "${CMAKE_BUILD_TYPE} version")
+
+ include_directories(${PCRE_INCLUDE_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
+@@ -31,6 +32,9 @@
+
+ add_subdirectory(examples)
+
++install(TARGETS da DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(FILES dac.h dac_json.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
++
+ if (EXISTS "${PROJECT_SOURCE_DIR}/tests")
+ subdirs(tests)
+ endif()