summaryrefslogtreecommitdiff
path: root/dev-libs/device-atlas-api-c/files/2.1.2-src-cmakelists.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/device-atlas-api-c/files/2.1.2-src-cmakelists.patch')
-rw-r--r--dev-libs/device-atlas-api-c/files/2.1.2-src-cmakelists.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-libs/device-atlas-api-c/files/2.1.2-src-cmakelists.patch b/dev-libs/device-atlas-api-c/files/2.1.2-src-cmakelists.patch
new file mode 100644
index 000000000000..b81768aba648
--- /dev/null
+++ b/dev-libs/device-atlas-api-c/files/2.1.2-src-cmakelists.patch
@@ -0,0 +1,18 @@
+--- a/Src/CMakeLists.txt.orig 2017-05-20 22:56:14.138401705 +0100
++++ b/Src/CMakeLists.txt 2017-05-20 22:58:11.376354697 +0100
+@@ -18,6 +18,7 @@
+ set(MODEL 64)
+ endif()
+
++include(GNUInstallDirs)
+ message(STATUS "${CMAKE_BUILD_TYPE} version")
+
+ include_directories(${PCRE_INCLUDE_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
+@@ -37,5 +38,5 @@
+ set (CMAKE_SHARED_LINKER_FLAGS -m32)
+ endif()
+
+-install(FILES libda.so libda.so.${API_VERSION} DESTINATION /usr/local/lib)
+-install(FILES dac.h dac_json.h DESTINATION /usr/local/include)
++install(TARGETS da DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(FILES dac.h dac_json.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})