summaryrefslogtreecommitdiff
path: root/dev-libs/efl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/efl')
-rw-r--r--dev-libs/efl/Manifest2
-rw-r--r--dev-libs/efl/efl-1.28.0.ebuild302
2 files changed, 304 insertions, 0 deletions
diff --git a/dev-libs/efl/Manifest b/dev-libs/efl/Manifest
index 381b47a390fe..61973d5e8434 100644
--- a/dev-libs/efl/Manifest
+++ b/dev-libs/efl/Manifest
@@ -1,4 +1,6 @@
AUX efl-1.27-eina_string_view.patch 1384 BLAKE2B a2582818ff1a0f0bf5c3ebb70256cf449c1196ef1d409cbd4bcd5f7e5b1d7b51331a3350a0200211204a8743b099e23d8b6b5f349f130046546609d127dd3aad SHA512 9024545ec77be7582862c3b38dc2c718d8df93257f7025a0c4dbc8de3858dd4d9815c570386c9b2327581d757e3e34d527f7499040ea7406917684098ea94cd7
DIST efl-1.27.0.tar.xz 168543208 BLAKE2B 082f7089f1a017db8e62f36fb2a51e18c7d00b74b8e865a60d066e49921c69720101deb3184a125633a6c646e241b8765cccc038c906c00d4ca16ecb705faf6f SHA512 5dda2f630463a2504d9246be17449579bbc470904e137b02b3b5c44db033dec2688f6c477885de1485944d875ee62619b6e7c5d4d3657225951f6feaf83b4fa4
+DIST efl-1.28.0.tar.xz 168556580 BLAKE2B d40cc99a5512c81931ba6d8459ff3941406a377cf17131300a2681a180e40467526ea71039c5d4bcaf8c4fe192d3b656a168333a75a0d5d3f7bbc7c681ec3c61 SHA512 f88b005f981f09496baac0a1232c26433ad80acc5957a0a972a9b1335dda111d8defbfd7ed0ed6a7ead1528d58fef4f7ed53c60b87f33c625fb22f38683a890d
EBUILD efl-1.27.0-r1.ebuild 8110 BLAKE2B 1ded95f800d9c459c6e6248c49302146b3d3e79acdc461146a3377eff724abca595b5351d08393efc6a2ff103691e79c639f28f76b0d0b893f1d55b2a4c4e307 SHA512 4dbcfad9f03f59d857b421368b7ae401f0744343935148b4885c6cf718fb7c9ad12bfcba3535fd194a6a13f36e0785cc7b4822cac8e15e880bd2bfb5317c26b4
+EBUILD efl-1.28.0.ebuild 8119 BLAKE2B 8ca969ddbcb0a8547515af9fffe5f11723e07f162dd77ec2cdd13f5fa61410e3902bf0a12f0442e13e2f874be44123ef63515c461d0ee2ccd4a054cb6a905732 SHA512 ec4b35334463a84f11e98183e04b3dbe4f3d8096a5e0d82c48773a315ffab4b89d2d78139cd4dd25eca3570bbf1a7c7fbd9d076ef1c5d991e6911ba28c96d2af
MISC metadata.xml 1835 BLAKE2B 9057e58727f82d085606315896cca8f37f81fc9642cb3d40fed53f07ae09bedfd6d1d1a23878bca9e7e2713314d83c26dcfbf305557cfdfbeeeb01bfb73b2867 SHA512 ac1d09983c4f6e992dd92cc6aa4770a6a847be3a4f5b4236867d411f5c730e8b743574864b948301782eedd72e78dfdd6e7a4deeffd4a09f2f52f958e9a1e6c7
diff --git a/dev-libs/efl/efl-1.28.0.ebuild b/dev-libs/efl/efl-1.28.0.ebuild
new file mode 100644
index 000000000000..04c679ce28e5
--- /dev/null
+++ b/dev-libs/efl/efl-1.28.0.ebuild
@@ -0,0 +1,302 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_REQ_USE="deprecated(+)"
+LUA_COMPAT=( lua5-{1,2} luajit )
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit lua-single meson python-any-r1 xdg
+
+DESCRIPTION="Enlightenment Foundation Libraries all-in-one package"
+HOMEPAGE="https://www.enlightenment.org"
+SRC_URI="https://download.enlightenment.org/rel/libs/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+X avif bmp connman cpu_flags_arm_neon dds debug doc drm +eet efl-one elogind examples fbcon"
+IUSE+=" +fontconfig fribidi gif glib +gstreamer harfbuzz heif hyphen ibus ico jpeg2k jpegxl json"
+IUSE+=" nls mono opengl +pdf physics pmaps postscript psd pulseaudio raw scim sdl +sound +svg"
+IUSE+=" +system-lz4 systemd tga tgv tiff tslib unwind v4l vnc wayland webp xcf xim xpm xpresent"
+IUSE+=" zeroconf"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ ?? ( elogind systemd )
+ ?? ( fbcon tslib )
+ drm? ( wayland )
+ examples? ( eet svg )
+ gstreamer? ( sound )
+ ibus? ( glib )
+ opengl? ( X )
+ pulseaudio? ( sound )
+ xim? ( X )
+ xpresent? ( X )"
+
+# Requires everything to be enabled unconditionally.
+RESTRICT="test"
+
+RDEPEND="${LUA_DEPS}
+ dev-libs/libinput:=
+ dev-libs/libunibreak:=
+ dev-libs/openssl:0=
+ net-misc/curl
+ media-libs/giflib:=
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/zlib
+ X? (
+ !opengl? ( media-libs/libglvnd )
+ media-libs/freetype
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libxkbcommon
+ wayland? ( x11-libs/libxkbcommon[X] )
+ )
+ avif? ( media-libs/libavif:= )
+ connman? ( net-misc/connman )
+ drm? (
+ dev-libs/libinput:=
+ dev-libs/wayland
+ media-libs/mesa[gbm(+)]
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ )
+ elogind? (
+ sys-auth/elogind
+ virtual/libudev:=
+ )
+ fontconfig? (
+ media-libs/fontconfig
+ media-libs/freetype
+ )
+ fribidi? ( dev-libs/fribidi )
+ glib? ( dev-libs/glib:2 )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ harfbuzz? ( media-libs/harfbuzz:= )
+ heif? ( media-libs/libheif:= )
+ hyphen? ( dev-libs/hyphen )
+ ibus? ( app-i18n/ibus )
+ jpeg2k? ( media-libs/openjpeg:= )
+ jpegxl? ( media-libs/libjxl:= )
+ json? ( >=media-libs/rlottie-0.0.1_pre20200424:= )
+ mono? ( dev-lang/mono )
+ opengl? ( virtual/opengl )
+ pdf? ( app-text/poppler:=[cxx] )
+ physics? ( sci-physics/bullet:= )
+ postscript? ( app-text/libspectre )
+ pulseaudio? ( media-libs/libpulse )
+ raw? ( media-libs/libraw:= )
+ scim? ( app-i18n/scim )
+ sdl? ( media-libs/libsdl2 )
+ sound? ( media-libs/libsndfile )
+ svg? ( gnome-base/librsvg:2 )
+ system-lz4? ( app-arch/lz4:= )
+ systemd? ( sys-apps/systemd:= )
+ tiff? ( media-libs/tiff:= )
+ tslib? ( x11-libs/tslib:= )
+ unwind? ( sys-libs/libunwind:= )
+ v4l? ( media-libs/libv4l )
+ vnc? ( net-libs/libvncserver )
+ wayland? (
+ dev-libs/wayland
+ media-libs/libglvnd
+ media-libs/mesa[wayland]
+ x11-libs/libxkbcommon
+ )
+ webp? ( media-libs/libwebp:= )
+ xpm? ( x11-libs/libXpm )
+ xpresent? ( x11-libs/libXpresent )
+ zeroconf? ( net-dns/avahi )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ wayland? ( dev-libs/wayland-protocols )"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( app-text/doxygen )
+ examples? ( sys-devel/gettext )
+ mono? ( dev-build/cmake )
+ nls? ( sys-devel/gettext )
+ wayland? ( dev-util/wayland-scanner )"
+
+pkg_setup() {
+ # Deprecated, provided for backward-compatibility. Everything is moved to libefreet.so.
+ QA_FLAGS_IGNORED="/usr/$(get_libdir)/libefreet_trash.so.${PV}
+ /usr/$(get_libdir)/libefreet_mime.so.${PV}"
+
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Remove automagic unwind configure option, #743154
+ if ! use unwind; then
+ sed -i "/config_h.set('HAVE_UNWIND/,/eina_ext_deps += unwind/d" src/lib/eina/meson.build ||
+ die "Failed to remove libunwind dep"
+ fi
+
+ # Fix python shebangs for python-exec[-native-symlinks], #764086
+ local shebangs=($(grep -rl "#!/usr/bin/env python3" || die))
+ python_fix_shebang -q ${shebangs[*]}
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dbuffer=false
+ -Dbuild-tests=false
+ -Dcocoa=false
+ -Ddrm-deprecated=false
+ -Dembedded-libunibreak=false
+ -Dg-mainloop=false
+ -Dmono-beta=false
+ -Ddotnet=false
+ -Dpixman=false
+ -Dwl-deprecated=false
+
+ -Dedje-sound-and-video=true
+ -Deeze=true
+ -Dinput=true
+ -Dinstall-eo-files=true
+ -Dlibmount=true
+ -Dnative-arch-optimization=true
+ -Dxinput2=true
+ -Dxinput22=true
+
+ -Dcrypto=openssl
+ -Ddotnet-stylecop-severity=Warning
+
+ $(meson_use X x11)
+ $(meson_use debug debug-threads)
+ $(meson_use doc docs)
+ $(meson_use drm)
+ $(meson_use examples build-examples)
+ $(meson_use fbcon fb)
+ $(meson_use fontconfig)
+ $(meson_use fribidi)
+ $(meson_use glib)
+ $(meson_use gstreamer)
+ $(meson_use harfbuzz)
+ $(meson_use hyphen)
+ $(meson_use lua_single_target_luajit elua)
+ $(meson_use nls)
+ $(meson_use physics)
+ $(meson_use pulseaudio)
+ $(meson_use sdl)
+ $(meson_use sound audio)
+ $(meson_use tslib)
+ $(meson_use v4l v4l2)
+ $(meson_use vnc vnc-server)
+ $(meson_use wayland wl)
+ $(meson_use xpresent)
+ $(meson_use zeroconf avahi)
+
+ $(meson_use !system-lz4 embedded-lz4)
+ )
+
+ if use elogind || use systemd; then
+ emesonargs+=( -D systemd=true )
+ else
+ emesonargs+=( -D systemd=false )
+ fi
+
+ if use wayland; then
+ emesonargs+=( -D opengl=es-egl )
+ elif ! use wayland && use opengl; then
+ emesonargs+=( -D opengl=full )
+ elif ! use wayland && use X && ! use opengl; then
+ emesonargs+=( -D opengl=es-egl )
+ else
+ emesonargs+=( -D opengl=none )
+ fi
+
+ if use connman; then
+ emesonargs+=( -D network-backend=connman )
+ else
+ emesonargs+=( -D network-backend=none )
+ fi
+
+ local disabledEvasLoaders=""
+ ! use avif && disabledEvasLoaders="avif,"
+ ! use bmp && disabledEvasLoaders+="bmp,wbmp,"
+ ! use dds && disabledEvasLoaders+="dds,"
+ ! use eet && disabledEvasLoaders+="eet,"
+ ! use gstreamer && disabledEvasLoaders+="gst,"
+ ! use heif && disabledEvasLoaders+="heif,"
+ ! use ico && disabledEvasLoaders+="ico,"
+ ! use jpeg2k && disabledEvasLoaders+="jp2k,"
+ ! use jpegxl && disabledEvasLoaders+="jxl,"
+ ! use json && disabledEvasLoaders+="json,"
+ ! use pdf && disabledEvasLoaders+="pdf,"
+ ! use pmaps && disabledEvasLoaders+="pmaps,"
+ ! use postscript && disabledEvasLoaders+="ps,"
+ ! use psd && disabledEvasLoaders+="psd,"
+ ! use raw && disabledEvasLoaders+="raw,"
+ ! use svg && disabledEvasLoaders+="rsvg,svg,"
+ ! use tga && disabledEvasLoaders+="tga,"
+ ! use tgv && disabledEvasLoaders+="tgv,"
+ ! use tiff && disabledEvasLoaders+="tiff,"
+ ! use webp && disabledEvasLoaders+="webp,"
+ ! use xcf && disabledEvasLoaders+="xcf,"
+ ! use xpm && disabledEvasLoaders+="xpm,"
+ [[ ! -z "$disabledEvasLoaders" ]] && disabledEvasLoaders=${disabledEvasLoaders::-1}
+ emesonargs+=( -D evas-loaders-disabler="${disabledEvasLoaders}" )
+
+ local disabledImfLoaders=""
+ ! use ibus && disabledImfLoaders+="ibus,"
+ ! use scim && disabledImfLoaders+="scim,"
+ ! use xim && disabledImfLoaders+="xim,"
+ [[ ! -z "$disabledImfLoaders" ]] && disabledImfLoaders=${disabledImfLoaders::-1}
+ emesonargs+=( -D ecore-imf-loaders-disabler="${disabledImfLoaders}" )
+
+ local bindingsList="cxx,"
+ use lua_single_target_luajit && bindingsList+="lua,"
+ use mono && bindingsList+="mono,"
+ [[ ! -z "$bindingsList" ]] && bindingsList=${bindingsList::-1}
+ emesonargs+=( -D bindings="${bindingsList}" )
+
+ local luaChoice=""
+ if use lua_single_target_luajit; then
+ luaChoice+="luajit"
+ else
+ luaChoice+="lua"
+ fi
+ emesonargs+=( -D lua-interpreter="${luaChoice}" )
+
+ # Not all arm CPU's have neon instruction set, #722552
+ if use arm && ! use cpu_flags_arm_neon; then
+ emesonargs+=( -D native-arch-optimization=false )
+ fi
+
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+}
+
+src_install() {
+ meson_src_install
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples/
+ dodoc -r "${BUILD_DIR}"/src/examples/
+ fi
+}