summaryrefslogtreecommitdiff
path: root/dev-libs/eventlog/eventlog-0.2.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/eventlog/eventlog-0.2.12.ebuild')
-rw-r--r--dev-libs/eventlog/eventlog-0.2.12.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/dev-libs/eventlog/eventlog-0.2.12.ebuild b/dev-libs/eventlog/eventlog-0.2.12.ebuild
index 4314da457d3d..528c481f39e5 100644
--- a/dev-libs/eventlog/eventlog-0.2.12.ebuild
+++ b/dev-libs/eventlog/eventlog-0.2.12.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit libtool eutils ltprune
+EAPI=7
+
+inherit libtool
DESCRIPTION="Support library for syslog-ng"
HOMEPAGE="http://www.balabit.com/products/syslog_ng/"
@@ -10,12 +11,14 @@ SRC_URI="http://www.balabit.com/downloads/files/eventlog/0.2//eventlog_${PV}.tar
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
IUSE="static-libs"
-DEPEND=""
+DOCS=( AUTHORS CREDITS ChangeLog NEWS PORTS README )
src_prepare() {
+ default
+
elibtoolize
}
@@ -24,7 +27,7 @@ src_configure() {
}
src_install() {
- DOCS="AUTHORS CREDITS ChangeLog NEWS PORTS README" \
- default
- prune_libtool_files
+ default
+
+ find "${ED}" -name '*.la' -delete || die
}