summaryrefslogtreecommitdiff
path: root/dev-libs/gjs
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gjs')
-rw-r--r--dev-libs/gjs/Manifest2
-rw-r--r--dev-libs/gjs/gjs-1.80.2.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index cce9cac0120f..77d3e2f391cc 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,3 +1,5 @@
DIST gjs-1.78.5.tar.xz 656168 BLAKE2B e1458d000998b66fda90e448ca487e591729e003c3e11a939dc474958b6de55783d41db8de5b243a329361f12acc15a8e84f4131650705becb046b68c54a24a2 SHA512 bb25e52dff53bfbde6d2329027d4ff68849740cf753da58f9bdf5a19ea7b029e2517d67978f461f16660dd1aa48b223798e9c0a24cde0ccb62060e4a0c83a02e
+DIST gjs-1.80.2.tar.xz 663256 BLAKE2B d5c8dd85acc0ee1fa8da9450b1d9427da0f835b695d5c6877ea166d41751dcf4449bb00ee0068ac98abed245d6dc1d67504432db368b9fcd8d81e0f37e72e952 SHA512 cc9a9073f741ee60eff2d2ce808cca7f40e97798f9ffa9197ebc3780a8a5df6e174ba76293bf7547fc8fa7e82be6a828a633a5aa8ba27d551dec72d635b6c5bd
EBUILD gjs-1.78.5.ebuild 1958 BLAKE2B 28917b22ebc65380e8e451bbfaf0ff9163da52ca693ccd129bd8ac12bdc974f0bc1e4e097320dc6281e20e9ed34b2fc8f1d45a53c5455065f4067b801365b16b SHA512 d9540bb0617590e398e34b6a37cc9624dd11f54395133442237fb3dc4dd8b3f186cfcf8d4e63dc5b5b1d85c938363e5ecaefbae09a1936c740a7d01b133eb691
+EBUILD gjs-1.80.2.ebuild 1927 BLAKE2B b0af1d14cfbb917a4245d29dfc54727ab4ee400679230a9f8e77f8c6893969ba594e52f5bc56ed961ee5a0c4d052b572baba4cea540b624682bca06622426ca5 SHA512 d1afe0841410e829e3c39f337cbb6a243bf5a44d36f6166eb7d38cd87ab9057170d7902babd2aa2abffe2382652cc5323e76c85aba2e4aaa00e6a7458246bc47
MISC metadata.xml 473 BLAKE2B 0d57ec402b3daaa00af170335374e711150ecccd019aea100484079a055015f36119c4564ae2d95e82e4ac8d6de6d84b83379aedfdcbfb7aaabaa752b51d8203 SHA512 a4f99ef450b30c381845a774865b4e82b2a554cc7f0a2edba7002096563943b58b290f704210cc00ca0508cf6e81a11be2fa0c6402117d2b05f0e4eb2e03a0c2
diff --git a/dev-libs/gjs/gjs-1.80.2.ebuild b/dev-libs/gjs/gjs-1.80.2.ebuild
new file mode 100644
index 000000000000..13f066ff2ada
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.80.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gnome.org meson virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+cairo examples readline sysprof test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ dev-libs/libffi:=
+ >=dev-libs/gobject-introspection-1.71.1:=
+ dev-lang/spidermonkey:115
+ cairo? ( x11-libs/cairo[X,glib] )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ >=x11-libs/gtk+-3.20:3[introspection]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ -Db_pch=True # TODO this has to go
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}