summaryrefslogtreecommitdiff
path: root/dev-libs/http-fetcher
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/http-fetcher')
-rw-r--r--dev-libs/http-fetcher/Manifest3
-rw-r--r--dev-libs/http-fetcher/files/http-fetcher-1.1.0-underquoted-http-fetcher-macro.patch13
-rw-r--r--dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild (renamed from dev-libs/http-fetcher/http-fetcher-1.1.0-r1.ebuild)11
3 files changed, 22 insertions, 5 deletions
diff --git a/dev-libs/http-fetcher/Manifest b/dev-libs/http-fetcher/Manifest
index 3d366a005db5..61d299dd446c 100644
--- a/dev-libs/http-fetcher/Manifest
+++ b/dev-libs/http-fetcher/Manifest
@@ -1,3 +1,4 @@
+AUX http-fetcher-1.1.0-underquoted-http-fetcher-macro.patch 400 BLAKE2B c46aa6a28b89139d54484229562efd42856fc359ae2a3544015a11623ecfb3adc13e4a1d700d109fe4cf402be3757fe7ad873e36dc8d8806b39a4ff8f9dd8b47 SHA512 c2365e63552f3231dcc30976bdeea5b362bcc8952e425b02f8a785e58ffebc953ab46f9ab002da5e933ba0d56c15fcbeba284ee30a0482e88938ae01b4273783
DIST http_fetcher-1.1.0.tar.gz 382470 BLAKE2B 6d2c7139d3e9435ff993fd5cd097c1b85b8900e048e6f93fc5e4f61f44f1eb47e0b9cd04c90985c15391ce862356a47acb56bfd8ff16050ca562095c80cb3f12 SHA512 136eceabc317bc4bf9956272ebbdae735ff589012ed0b17210fdb70051389bb7b3c1b43cdfc322a340e5538e9fd60b7b5216d3d46c439ac9df6af29e621bb1fa
-EBUILD http-fetcher-1.1.0-r1.ebuild 702 BLAKE2B dfb34c5218c987046d448681735e6d89b2c754ff14734e53418a58bef518bb48d8cfdcd09ceabe8cefc0c59e264052ea3f1a16af808410de686277bba0b52077 SHA512 f3350413ebd398299c6e0640644e11708498a693aabb0efcfc7b13ba4ec8abda27807c1a3d73e7774bcb81f33f451e0eab93cc0e02ee207f173227b6ab80064e
+EBUILD http-fetcher-1.1.0-r2.ebuild 758 BLAKE2B ef782de1eddb484e57a08f7d1d4d29db7deed6e39fa873ddfa1aeba1e882c0a1f69a5c84994cb87e25952def7e69c2fc7ef3f9bd7eb059a2558d8dd576e1b39e SHA512 793f6ca32d1f9b2f0e6d006461f6beee0a5e2bc0173fc26240c7268f1887ec1f96102c7b9e0f2ba69c8bc8d550cf4b7c1067f460eb7ba60c81f2f5e74ba05bef
MISC metadata.xml 334 BLAKE2B 2199d5121970f910ba8e8636327da1c5969aa21b1b30d8dded9b352f1651c78f0623eab71247b3dbcba4f2acccf9912e6791e6949dbaff30c93175c5ff1e60d3 SHA512 13a4b58689a3237aa0ae9c432289d29ea7dd3405c44f24fb6c9fbeb8d964ced4df5b0840a6b215b4b4cace8dbbf6cf2ad1a6e465ef9d60abf2ddcbad7b65d829
diff --git a/dev-libs/http-fetcher/files/http-fetcher-1.1.0-underquoted-http-fetcher-macro.patch b/dev-libs/http-fetcher/files/http-fetcher-1.1.0-underquoted-http-fetcher-macro.patch
new file mode 100644
index 000000000000..2135de07851e
--- /dev/null
+++ b/dev-libs/http-fetcher/files/http-fetcher-1.1.0-underquoted-http-fetcher-macro.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/876911
+https://bugs.gentoo.org/299940
+--- a/http-fetcher.m4
++++ b/http-fetcher.m4
+@@ -10,7 +10,7 @@ dnl understanding is that this should only be done if necessary.
+ dnl The macro also adds the appropriate -L and -I values to CFLAGS so that
+ dnl headers are found and libraries are linked.
+ dnl
+-AC_DEFUN(AC_PATH_HFETCHER,
++AC_DEFUN([AC_PATH_HFETCHER],
+ [dnl
+
+ darwin=no;
diff --git a/dev-libs/http-fetcher/http-fetcher-1.1.0-r1.ebuild b/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
index 0d694ccc9dd4..97ad5484327a 100644
--- a/dev-libs/http-fetcher/http-fetcher-1.1.0-r1.ebuild
+++ b/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
@@ -10,14 +10,18 @@ MY_P="${P/-/_}"
DESCRIPTION="Library for downloading files via HTTP using the GET method"
HOMEPAGE="http://http-fetcher.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 ppc x86"
IUSE="debug"
S="${WORKDIR}/${MY_P}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-underquoted-http-fetcher-macro.patch
+)
+
src_prepare() {
default
eautoreconf
@@ -26,7 +30,6 @@ src_prepare() {
src_configure() {
econf \
--disable-strict \
- --disable-static \
$(use_enable debug)
}