summaryrefslogtreecommitdiff
path: root/dev-libs/icu-layoutex
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/icu-layoutex')
-rw-r--r--dev-libs/icu-layoutex/Manifest2
-rw-r--r--dev-libs/icu-layoutex/icu-layoutex-68.2.ebuild109
2 files changed, 0 insertions, 111 deletions
diff --git a/dev-libs/icu-layoutex/Manifest b/dev-libs/icu-layoutex/Manifest
index 036cbae5bcf9..c64789b359d9 100644
--- a/dev-libs/icu-layoutex/Manifest
+++ b/dev-libs/icu-layoutex/Manifest
@@ -1,6 +1,4 @@
AUX icu-layoutex-65.1-remove-bashisms.patch 4963 BLAKE2B fb781741a7a908638876729d573a73e42b7b3f0f3e692b54799fed0dac006ecb731583d90d849ea06be47259a0a236933fa7a78a96b3a8107ee85f916dc2000a SHA512 67e60068c356ca8d93b137eadeef2562ff7d8f38153babc97edd92a2c38d7113396d63d4a09364dacefc612b4b3ea28872a4f767c4f38d3e725943b32f98c5bc
-DIST icu4c-68_2-src.tgz 24737478 BLAKE2B ff54f903aed1a16928656e5f4fee79e4301038a70ba1d389fb2a2cc7c7dc4c76bc2430c810cea484c0ef69fbafc5728e71776c39874a5395c9dd06d573e8ea90 SHA512 24f3b7981667b37df58118f56ae76a09b719358c1efa8d6f044d28ef8df1c722a894957acadfb3c37aee39ac845893924fc3370d6bbe09875aec8d937059f84b
DIST icu4c-69_1-src.tgz 24814903 BLAKE2B ef95a04e238f0de96e969d580ef64000ab04a4a0003e8f31fd02baab35387d5ab2c4d792ae0d14f3de8e48aa28570237ccd67fb32e03b13d1572e4a995b1de76 SHA512 d4aeb781715144ea6e3c6b98df5bbe0490bfa3175221a1d667f3e6851b7bd4a638fa4a37d4a921ccb31f02b5d15a6dded9464d98051964a86f7b1cde0ff0aab7
-EBUILD icu-layoutex-68.2.ebuild 2503 BLAKE2B 5c5bfd5784eda15dc43f871c4f2a178a4860e2af59bb1a535e3e0029d988c2084567d92e464b084efbbff0c0fa149b69b1e23f0c8ae662f50e44d7f9cf32bb2a SHA512 bdf1ef449aca671bdad889d213183b6e9c02be1b23af916f1db8d3a3f256442bcb770dc809bf881777593743aae6904e30f8b872d74e901b3c31e8b09b2e7037
EBUILD icu-layoutex-69.1.ebuild 2503 BLAKE2B 5c5bfd5784eda15dc43f871c4f2a178a4860e2af59bb1a535e3e0029d988c2084567d92e464b084efbbff0c0fa149b69b1e23f0c8ae662f50e44d7f9cf32bb2a SHA512 bdf1ef449aca671bdad889d213183b6e9c02be1b23af916f1db8d3a3f256442bcb770dc809bf881777593743aae6904e30f8b872d74e901b3c31e8b09b2e7037
MISC metadata.xml 379 BLAKE2B 7dd7c9bef21ada3af657ec75d323fa890bb02e04b1760fb5791bdbddf8d5eaa1126ab80058e73977a5bede8c8e655f9fc7045f43d4fadcb0213ea8a122258380 SHA512 45e7eab7e7d954331f7d64582eaef71c18316335fca7cbf6bbdf8e71555301e995ff7ab04e35977be8a82fc8360af00115567aeddd710b253c6a68fd893228aa
diff --git a/dev-libs/icu-layoutex/icu-layoutex-68.2.ebuild b/dev-libs/icu-layoutex/icu-layoutex-68.2.ebuild
deleted file mode 100644
index 1f04fa03da06..000000000000
--- a/dev-libs/icu-layoutex/icu-layoutex-68.2.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic multilib-minimal toolchain-funcs
-
-DESCRIPTION="External layout part of International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/"
-SRC_URI="https://github.com/unicode-org/icu/releases/download/release-${PV//./-}/icu4c-${PV//./_}-src.tgz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 sparc x86"
-IUSE="debug static-libs"
-
-BDEPEND="
- virtual/pkgconfig
-"
-DEPEND="
- ~dev-libs/icu-${PV}[${MULTILIB_USEDEP}]
- dev-libs/icu-le-hb[${MULTILIB_USEDEP}]
-"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PN/-layoutex}/source"
-
-PATCHES=(
- "${FILESDIR}/${PN}-65.1-remove-bashisms.patch"
-)
-
-src_prepare() {
- # apply patches
- default
-
- # Disable renaming as it is stupid thing to do
- sed -i \
- -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
- common/unicode/uconfig.h || die
-
- # Fix linking of icudata
- sed -i \
- -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
- config/mh-linux || die
-
- eautoreconf
-}
-
-src_configure() {
- # Use C++14
- append-cxxflags -std=c++14
-
- if tc-is-cross-compiler; then
- mkdir "${WORKDIR}"/host || die
- pushd "${WORKDIR}"/host >/dev/null || die
-
- CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
- CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
- RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
- "${S}"/configure --disable-renaming --disable-debug \
- --disable-samples --enable-static || die
- emake
-
- popd >/dev/null || die
- fi
-
- multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-renaming
- --disable-samples
- --enable-layoutex
- $(use_enable debug)
- $(use_enable static-libs static)
- )
-
- tc-is-cross-compiler && myeconfargs+=(
- --with-cross-build="${WORKDIR}"/host
- )
-
- # icu tries to use clang by default
- tc-export CC CXX
-
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- # INTLTEST_OPTS: intltest options
- # -e: Exhaustive testing
- # -l: Reporting of memory leaks
- # -v: Increased verbosity
- # IOTEST_OPTS: iotest options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- # CINTLTST_OPTS: cintltst options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- pushd layoutex &>/dev/null || die
- emake -j1 VERBOSE="1" check
- popd &>/dev/null || die
-}
-
-multilib_src_install() {
- pushd layoutex &>/dev/null || die
- default
- popd &>/dev/null || die
-}