summaryrefslogtreecommitdiff
path: root/dev-libs/igraph
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/Manifest2
-rw-r--r--dev-libs/igraph/igraph-0.10.15.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/igraph/Manifest b/dev-libs/igraph/Manifest
index de780cebc7c1..c5dba8d3327a 100644
--- a/dev-libs/igraph/Manifest
+++ b/dev-libs/igraph/Manifest
@@ -1,5 +1,7 @@
DIST igraph-0.10.11.tar.gz 4349830 BLAKE2B 3aae088115148d1f965a52f01c950000097520fb0a150d2ad1fabb96cff434a9b548a6c17a10b9e0ebad3a577c2423ac5260cd28223147d3dc71b0d4fe139a95 SHA512 d6978589f12ed20b87777394b46f47b4ffc045ef693e5b4fc90163b9482361b2bf0ed2bb04aa99bf4a0653f7e4355cd480b0a165213d90ff7188ef6c86147c86
DIST igraph-0.10.12.tar.gz 4373463 BLAKE2B b7fdd7046185bf501c9302721f6606e6affc0d91c16d195c6bd69e0b32f9dca7af701a963fd4a8b8558ac843fe4a5136c7fce2fe5595db469818e514db2325ac SHA512 1a7b055ab2148fdf04187d785895b930ae2a54ae0240ea9656e129a38347b1caeb28dda5a3a7e34282462363150d7afd25acf8cd335577ed441b8a5cecc0dd25
+DIST igraph-0.10.15.tar.gz 4439424 BLAKE2B 183ab0d1c2fbbb0867fbb3df92307242aebbe435283a07ca21fd688446238590bae0f2584e5b7eba550f3864d1746c42fc8d7c2196ded9ec226e8d625d1c9097 SHA512 bf9f0f2f62618cf037bdbbf2e126d27ec4e45edfb65efcf26df3fc1fb71a3e1f05a8b9a62f972650d96daa1e7bd3f2a084fe39bbca42e808cc737165514276e0
EBUILD igraph-0.10.11.ebuild 1056 BLAKE2B 1b5873fb57be9a76536cb5f17e1c22b5ed71a99a4b23ed7714005e09b8ec86b939c06c763c3b8e81c127f8f11bd7c0fa32fc8d398de1e5849b1241651acfe5cd SHA512 9e3a91f79f2ff58bcfe054e7bbb9234bf91be040b0623b4032cf2c98c8355d4f812e96c4ec4462d2d74c07dfaf053dc89a6f33753d845bb61203744c1d6daa26
EBUILD igraph-0.10.12.ebuild 1056 BLAKE2B 1b5873fb57be9a76536cb5f17e1c22b5ed71a99a4b23ed7714005e09b8ec86b939c06c763c3b8e81c127f8f11bd7c0fa32fc8d398de1e5849b1241651acfe5cd SHA512 9e3a91f79f2ff58bcfe054e7bbb9234bf91be040b0623b4032cf2c98c8355d4f812e96c4ec4462d2d74c07dfaf053dc89a6f33753d845bb61203744c1d6daa26
+EBUILD igraph-0.10.15.ebuild 1058 BLAKE2B 1062e026480a8ae78329aacd2ac8e5efd3d3a1d6f6278c214b6df23211582a552f61db50fae264688181b862bd5d2bb3366f587beeaec2a76f7a1e25c484c7a6 SHA512 32c5fb68f3983599f83211a82e35b590507f1f9865922a61678acd01f9ca29960e98e10babcbb8804170cb3722f3fb7c933d73172ea0173309251fc28525ee61
MISC metadata.xml 758 BLAKE2B 90df5f127db20d8d486a195a6c10d1e2159d2ca8ba1706adfec85c5317ef9b831ddf3595ab0f157cb30627db863fdeb72ce05d14bcd07291ec4735fd73a5e6b0 SHA512 3a5a7afe9387658aa41d587588af41b3cfae0c269e7da4badae23180b18c9854964942c292849321bc2c76feadcd4098223642f56736ca7a21a009d673446801
diff --git a/dev-libs/igraph/igraph-0.10.15.ebuild b/dev-libs/igraph/igraph-0.10.15.ebuild
new file mode 100644
index 000000000000..7a2ba80dfc9e
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.10.15.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="https://igraph.org/"
+SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug test threads"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2
+ sci-libs/arpack
+ sci-mathematics/glpk:=
+ sci-mathematics/plfit
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_CCACHE=OFF
+ -DIGRAPH_GLPK_SUPPORT=ON
+ -DIGRAPH_GRAPHML_SUPPORT=ON
+ -DIGRAPH_USE_INTERNAL_ARPACK=OFF
+ -DIGRAPH_USE_INTERNAL_BLAS=OFF
+ -DIGRAPH_USE_INTERNAL_GLPK=OFF
+ -DIGRAPH_USE_INTERNAL_GMP=OFF
+ -DIGRAPH_USE_INTERNAL_LAPACK=OFF
+ -DIGRAPH_USE_INTERNAL_PLFIT=OFF
+ -DIGRAPH_ENABLE_TLS=$(usex threads)
+ -DIGRAPH_WARNINGS_AS_ERRORS=OFF
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}