summaryrefslogtreecommitdiff
path: root/dev-libs/inih/inih-51.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/inih/inih-51.ebuild')
-rw-r--r--dev-libs/inih/inih-51.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/inih/inih-51.ebuild b/dev-libs/inih/inih-51.ebuild
new file mode 100644
index 000000000000..3cbd85dd6604
--- /dev/null
+++ b/dev-libs/inih/inih-51.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit meson multilib-minimal ninja-utils
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+
+DOCS=(
+ LICENSE.txt
+ README.md
+)
+
+S="${WORKDIR}/inih-r${PV}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}