summaryrefslogtreecommitdiff
path: root/dev-libs/keystone/keystone-0.9.2-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/keystone/keystone-0.9.2-r3.ebuild')
-rw-r--r--dev-libs/keystone/keystone-0.9.2-r3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-libs/keystone/keystone-0.9.2-r3.ebuild b/dev-libs/keystone/keystone-0.9.2-r3.ebuild
index bfc2d7d6fa78..0edae53eacbe 100644
--- a/dev-libs/keystone/keystone-0.9.2-r3.ebuild
+++ b/dev-libs/keystone/keystone-0.9.2-r3.ebuild
@@ -8,7 +8,7 @@ DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake distutils-r1
+inherit cmake distutils-r1 flag-o-matic
DESCRIPTION="assembly/assembler framework + bindings"
HOMEPAGE="https://www.keystone-engine.org/"
@@ -75,6 +75,9 @@ src_prepare() {
}
src_configure() {
+ # ODR violations in bundled LLVM (bug #924866)
+ filter-lto
+
local libdir="$(get_libdir)"
local mycmakeargs=(
-DCMAKE_CONFIGURATION_TYPES="Gentoo"