summaryrefslogtreecommitdiff
path: root/dev-libs/libIDL/libIDL-0.8.14-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libIDL/libIDL-0.8.14-r2.ebuild')
-rw-r--r--dev-libs/libIDL/libIDL-0.8.14-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libIDL/libIDL-0.8.14-r2.ebuild b/dev-libs/libIDL/libIDL-0.8.14-r2.ebuild
new file mode 100644
index 000000000000..aa649a61d9a1
--- /dev/null
+++ b/dev-libs/libIDL/libIDL-0.8.14-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="CORBA tree builder"
+HOMEPAGE="https://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.44.1-r1:2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local ECONF_SOURCE="${S}"
+ gnome2_src_configure --disable-static
+}
+
+multilib_src_compile() {
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}