summaryrefslogtreecommitdiff
path: root/dev-libs/libassuan/libassuan-2.5.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libassuan/libassuan-2.5.3.ebuild')
-rw-r--r--dev-libs/libassuan/libassuan-2.5.3.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-libs/libassuan/libassuan-2.5.3.ebuild b/dev-libs/libassuan/libassuan-2.5.3.ebuild
index 8a00919e7748..aca104db0f04 100644
--- a/dev-libs/libassuan/libassuan-2.5.3.ebuild
+++ b/dev-libs/libassuan/libassuan-2.5.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,10 +33,12 @@ src_prepare() {
}
src_configure() {
- econf \
- $(use_enable static-libs static) \
- GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config" \
- $("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config"
+ $("${S}/configure" --help | grep -o -- '--without-.*-prefix')
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {