summaryrefslogtreecommitdiff
path: root/dev-libs/libb64/libb64-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libb64/libb64-1.2.1.ebuild')
-rw-r--r--dev-libs/libb64/libb64-1.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/libb64/libb64-1.2.1.ebuild b/dev-libs/libb64/libb64-1.2.1.ebuild
new file mode 100644
index 000000000000..05a3299dffda
--- /dev/null
+++ b/dev-libs/libb64/libb64-1.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Fast Base64 encoding/decoding routines"
+HOMEPAGE="http://libb64.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="CC-PD"
+# static library, so always rebuild
+SLOT="0/${PVR}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+src_compile() {
+ # override -O3, -Werror non-sense
+ emake -C src CFLAGS="${CFLAGS} -I../include"
+}
+
+src_install() {
+ dolib src/libb64.a
+ insinto /usr/include
+ doins -r include/b64
+ dodoc AUTHORS BENCHMARKS CHANGELOG README
+}