summaryrefslogtreecommitdiff
path: root/dev-libs/libbsd
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/Manifest2
-rw-r--r--dev-libs/libbsd/libbsd-0.11.5.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libbsd/Manifest b/dev-libs/libbsd/Manifest
index d3f58a7f943f..a9cf8680cab7 100644
--- a/dev-libs/libbsd/Manifest
+++ b/dev-libs/libbsd/Manifest
@@ -1,3 +1,5 @@
DIST libbsd-0.11.3.tar.xz 399712 BLAKE2B 1af04b8fcbc0bfa59fba549639d61a33ac934fe7ee42b506d1b0452e0b836b0bfdd3d8739de90465be46fe6a9d326a2d11bcf72280aa19ccba81db5da6d63d89 SHA512 a7015ea1ffa3766b1a4690526a25231898ad8275149b31fb6801082450172249997c36165626d101ffce53b59767a46676eebc0806426922fe4e773a0376c1f5
+DIST libbsd-0.11.5.tar.xz 409972 BLAKE2B 00c89ad1be351e7851538eac2744f5aef87b5937330d514d17af8a20a04bc6eab0e2bda61d0080da1d1439306b3b191ab68b4bc4cd8558ff0adfe402bfbf5b52 SHA512 c52c19eddd53630aca14f9f6221f7b84aa9cc798b4bb91e867822b161793313aab872ac1c0350d29312a72fee6e2061f3910ff918b724ec171d8c9de5837c841
EBUILD libbsd-0.11.3.ebuild 1276 BLAKE2B 2f7c2b5e0e8787d2202ed3d2e66dc0f6d82d519e8877de6090633685bdced48d28cdf0948163cee674ae5dcf042e1aa67e2b87e7fca1ee922c9de7540d16c63f SHA512 f31cfbc348e390f479be6075d8bb5891fb2e37dcd04637e3bafa9a9dcc2f332325ab5f1f8b4d1c509f8474524953f09afc1da1b1d66bd3581102cf555b53f6c7
+EBUILD libbsd-0.11.5.ebuild 1053 BLAKE2B 5c0c7e80dcb7b10d5ea696dd970866439d44d0a53b2eeb570c8716b7a0458e35b2a714c19c145718f1782830a548be8b43d988e1c8bc1960b5dacad358ae9602 SHA512 91b9af7545f827a2c1af4270b3186b4de742f8f314699a1ebc1b0db0bf1be8907107940848aad726d8f55f7930c115e5fab84dd1f541b703f1bc1d0c863d12a4
MISC metadata.xml 363 BLAKE2B a1c4a829ec2dabf18360ab23b1aed4892f0650849a5287070fa15abffad4dc074d3c9c1fb698aa4da63262dcc1a4b57431654374c2f43764127daa389e7381d4 SHA512 5120ee7fb2fc2513df1a78a279d8d691969ee08d85ad2d960b5579069767eeb20087019a8a95d2f3c3f11d2ae721233a8283e47ad35d4c0fdbdef4cebc1ce930
diff --git a/dev-libs/libbsd/libbsd-0.11.5.ebuild b/dev-libs/libbsd/libbsd-0.11.5.ebuild
new file mode 100644
index 000000000000..55d75e728bd8
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.11.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="Library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="https://libbsd.freedesktop.org/wiki/ https://gitlab.freedesktop.org/libbsd/libbsd"
+SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="app-crypt/libmd[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-3.17
+"
+
+multilib_src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # https://gitlab.freedesktop.org/libbsd/libbsd/commit/c5b959028734ca2281250c85773d9b5e1d259bc8
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}