summaryrefslogtreecommitdiff
path: root/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libbulletml/libbulletml-0.0.6.ebuild')
-rw-r--r--dev-libs/libbulletml/libbulletml-0.0.6.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
index 045879e2c0f5..5bd9fa9717b4 100644
--- a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
+++ b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="A Library of Bullet Markup Language"
HOMEPAGE="https://shinh.skr.jp/libbulletml/index_en.html"
SRC_URI="https://shinh.skr.jp/libbulletml/${P}.tar.bz2"
@@ -10,25 +12,24 @@ SRC_URI="https://shinh.skr.jp/libbulletml/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
DEPEND="dev-libs/boost"
RDEPEND=${DEPEND}
-PATCHES=( "${FILESDIR}"/${P}-gcc4{3,6}.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc4{3,6}.patch
+ "${FILESDIR}"/${P}-Makefile.patch
+)
S="${WORKDIR}"/${PN#lib}/src
src_prepare() {
default
rm -r boost || die
-
- # don't override the system-wide flags
- sed -i -e '/^CFLAGS =/d;/^CXXFLAGS =/d' Makefile ygg/Makefile || die
}
-src_compile() {
- emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+src_configure() {
+ tc-export AR CXX
}
src_install() {