summaryrefslogtreecommitdiff
path: root/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libbulletml/libbulletml-0.0.6.ebuild')
-rw-r--r--dev-libs/libbulletml/libbulletml-0.0.6.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
index 8a90adf32396..045879e2c0f5 100644
--- a/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
+++ b/dev-libs/libbulletml/libbulletml-0.0.6.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils
+EAPI=7
DESCRIPTION="A Library of Bullet Markup Language"
-HOMEPAGE="http://shinh.skr.jp/libbulletml/index_en.html"
-SRC_URI="http://shinh.skr.jp/libbulletml/${P}.tar.bz2"
+HOMEPAGE="https://shinh.skr.jp/libbulletml/index_en.html"
+SRC_URI="https://shinh.skr.jp/libbulletml/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
@@ -16,12 +15,16 @@ IUSE=""
DEPEND="dev-libs/boost"
RDEPEND=${DEPEND}
-S=${WORKDIR}/${PN#lib}/src
+PATCHES=( "${FILESDIR}"/${P}-gcc4{3,6}.patch )
+
+S="${WORKDIR}"/${PN#lib}/src
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-gcc46.patch
+ default
rm -r boost || die
+
+ # don't override the system-wide flags
+ sed -i -e '/^CFLAGS =/d;/^CXXFLAGS =/d' Makefile ygg/Makefile || die
}
src_compile() {