summaryrefslogtreecommitdiff
path: root/dev-libs/libclsync
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libclsync')
-rw-r--r--dev-libs/libclsync/Manifest5
-rw-r--r--dev-libs/libclsync/files/libclsync-pthreads.patch13
-rw-r--r--dev-libs/libclsync/libclsync-0.4.4-r1.ebuild75
-rw-r--r--dev-libs/libclsync/metadata.xml2
4 files changed, 93 insertions, 2 deletions
diff --git a/dev-libs/libclsync/Manifest b/dev-libs/libclsync/Manifest
index 07f48f4dd4c5..e0d02ff26193 100644
--- a/dev-libs/libclsync/Manifest
+++ b/dev-libs/libclsync/Manifest
@@ -1,3 +1,6 @@
+AUX libclsync-pthreads.patch 441 BLAKE2B bbe3115799c436d1c13a6fd638822c6954f37fada8a6f7028ae1601e761ef1705badd5daf930ac1cc5bc2eb5e897ca1eb9f1d5c0161fa6358c979948a48ce097 SHA512 de0cc37af47903ff233941b7bc16fd381949c8450da736bbfc33c3e5d4da10c18b3d477e27d4a9f11848889c5ba0ad28d71ff355b82cc077123b37be357f25e1
DIST clsync-0.4.2.tar.gz 256042 BLAKE2B 28474fc66341b93705a502fcff390e3affcd89a9e1eb272dce9b28be709562e09c03e9c300cfeb5371e2e618a2239468a58c46212a39d751fbbfddeaab12bcf6 SHA512 d14a2efc4bf58d9d5c7a3fe5634cacdd182cd7cd814b0e9ebd99024a7282b056d1f7ceeec6903666391c3572d599a18e205af818b098ed7768d5c0e0f4cd1200
+DIST clsync-0.4.4.tar.gz 268276 BLAKE2B 0027760cfdee5c4410c4cea45aae2def6498d812d2f50038993c39a33c6029722ec2dd2cfff20815a3ffd8834eb8c439059e5f1d2cc3d2cf98ecb22ed22f2322 SHA512 cdafbf43fdeafe9cb53c08e0514ef356fb5b4bbd8da2226263180e7441d222c76e6c73f847f484b3688a8672e4a85df0346c0236d8d0ed4506d209189af02dcd
EBUILD libclsync-0.4.2.ebuild 1664 BLAKE2B b9b7e9db566ce8d6b6edaaf641a2653d23003d3e16f86498527a0caf590593784b99fa48694fcf88067f7e9300d0d7e5a96f0b2129ed99ce339834317d8e7214 SHA512 27a2ff3d0b00e3fb52413653d3823ad80c4fc6498bd93b5097e5a8369fc076632f45a341df07682cf82bd7511b426a0e492d1ffa086b558d684ed659227578bd
-MISC metadata.xml 718 BLAKE2B 30766db9a818c3dc8ed475fb0b885d20f6ff058eb2e493572923d9efa7708f29a8f9b91cb159a98e2683fbb268e8e44df7ea955098d574a4a707474abcb96e19 SHA512 4f5edc94ccb24487d3cf9f15dbc3c2e6666de4b22fdc8efe2daf10a2b9d31452d85cabe83403062383865d274aae826944da0756e2630af54b4055ac0fd87f64
+EBUILD libclsync-0.4.4-r1.ebuild 1709 BLAKE2B e637c6ea17fcb3ae342781477093fed46a630a45033f9e946e0dbe2ed25c357acbb9b2ffe6ac6bac11ae1b3c9c266b1e95984f014c5da442007fb33ccefb1d0f SHA512 3c57c148eb81e0910959b297cd752bb403890c1cd851a1a61c14ce28dbc0c97f96d4b737949f3d645eda59e6980c933f99f6cfc9c8e333d3e026eda69d745aa1
+MISC metadata.xml 716 BLAKE2B b8e44b73deea7153c841b292216050f8e050ac80e1851c267d98196d71ac9eb55f0786ca2db185c9ed094b9948bfba16ef3bed8224509970e1f7126a23232a5a SHA512 cb7e97539feb47f66f6a9e866ad85b95611412eba80dacc665bdf38a1a148c938812285fd6dc147f58be51f6801ec56df8c054f63a7bc142ced143958551bbc2
diff --git a/dev-libs/libclsync/files/libclsync-pthreads.patch b/dev-libs/libclsync/files/libclsync-pthreads.patch
new file mode 100644
index 000000000000..28a9fd8cd96a
--- /dev/null
+++ b/dev-libs/libclsync/files/libclsync-pthreads.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.am b/Makefile.am
+index 246908d..8bea3a9 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -98,7 +98,7 @@ EXTRA_DIST = .doxygen .travis.sh .travis.yml NOTES SHORTHANDS freebsd debian gen
+
+ if LIBCLSYNC
+ lib_LTLIBRARIES = libclsync.la
+-libclsync_la_SOURCES = malloc.c libclsync.c socket.c error.c
++libclsync_la_SOURCES = malloc.c libclsync.c socket.c error.c pthreadex.c
+ libclsync_la_LDFLAGS = -version-info 0:0:0
+ endif
+
diff --git a/dev-libs/libclsync/libclsync-0.4.4-r1.ebuild b/dev-libs/libclsync/libclsync-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..6d491e0caf83
--- /dev/null
+++ b/dev-libs/libclsync/libclsync-0.4.4-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN#lib}
+MY_P="${MY_PN}-${PV}"
+
+inherit autotools
+
+DESCRIPTION="Control and monitoring library for clsync"
+HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/clsync/clsync"
+SRC_URI="https://github.com/clsync/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug extra-debug extra-hardened hardened static-libs"
+S="${WORKDIR}/${MY_P}"
+
+REQUIRED_USE="
+ extra-debug? ( debug )
+ extra-hardened? ( hardened )
+"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="~app-doc/clsync-docs-${PV}"
+
+PATCHES=( "${FILESDIR}/${PN}-pthreads.patch" )
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ local harden_level=0
+ use hardened && harden_level=1
+ use extra-hardened && harden_level=2
+
+ local debug_level=0
+ use debug && debug_level=1
+ use extra-debug && debug_level=2
+
+ econf \
+ --enable-socket-library \
+ --disable-clsync \
+ --enable-debug=${debug_level} \
+ --enable-paranoid=${harden_level} \
+ --without-bsm \
+ --without-kqueue \
+ --disable-capabilities \
+ --disable-cluster \
+ --enable-socket \
+ --disable-highload-locks \
+ --disable-unshare \
+ --disable-seccomp \
+ --without-libcgroup \
+ --without-gio \
+ --with-inotify=native \
+ --without-mhash
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${ED}" -name "*.la" -delete
+ use static-libs || find "${ED}" -name "*.a" -delete || die "failed to remove static libs"
+
+ # docs go into clsync-docs
+ rm -rf "${ED}/usr/share/doc" || die
+}
+
+pkg_postinst() {
+ einfo "clsync instances you are going to use _must_ be compiled"
+ einfo "with control-socket support"
+}
diff --git a/dev-libs/libclsync/metadata.xml b/dev-libs/libclsync/metadata.xml
index 8c5ebe0c8bbd..4b856378c566 100644
--- a/dev-libs/libclsync/metadata.xml
+++ b/dev-libs/libclsync/metadata.xml
@@ -14,6 +14,6 @@
<flag name="extra-hardened">Enable extra security checks. This may hurt performance.</flag>
</use>
<upstream>
- <remote-id type="github">xaionaro/clsync</remote-id>
+ <remote-id type="github">clsync/clsync</remote-id>
</upstream>
</pkgmetadata>