summaryrefslogtreecommitdiff
path: root/dev-libs/libical/libical-2.0.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libical/libical-2.0.0-r3.ebuild')
-rw-r--r--dev-libs/libical/libical-2.0.0-r3.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-libs/libical/libical-2.0.0-r3.ebuild b/dev-libs/libical/libical-2.0.0-r3.ebuild
index d3d88590688d..18915f35433a 100644
--- a/dev-libs/libical/libical-2.0.0-r3.ebuild
+++ b/dev-libs/libical/libical-2.0.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -33,6 +33,7 @@ PATCHES=(
"${FILESDIR}/${P}-libical.pc-icu-remove-full-paths.patch"
"${FILESDIR}/${P}-libical.pc-icu-move-to-requires.patch"
"${FILESDIR}/${P}-libical.pc-fix-libdir-location.patch"
+ "${FILESDIR}/${P}-tests.patch" #bug 532296
)
src_configure() {
@@ -44,6 +45,11 @@ src_configure() {
cmake-utils_src_configure
}
+src_test() {
+ local myctestargs=( -j1 )
+ cmake-utils_src_test
+}
+
src_install() {
cmake-utils_src_install