summaryrefslogtreecommitdiff
path: root/dev-libs/libiconv/libiconv-1.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libiconv/libiconv-1.16.ebuild')
-rw-r--r--dev-libs/libiconv/libiconv-1.16.ebuild21
1 files changed, 8 insertions, 13 deletions
diff --git a/dev-libs/libiconv/libiconv-1.16.ebuild b/dev-libs/libiconv/libiconv-1.16.ebuild
index 6962ed176257..346661c34d79 100644
--- a/dev-libs/libiconv/libiconv-1.16.ebuild
+++ b/dev-libs/libiconv/libiconv-1.16.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,8 +15,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~s
IUSE="prefix static-libs"
DEPEND="!sys-libs/glibc
- !sys-libs/musl
- !userland_GNU? ( !sys-apps/man-pages )"
+ !sys-libs/musl"
RDEPEND="${DEPEND}"
PATCHES=(
@@ -44,14 +43,10 @@ multilib_src_configure() {
multilib_src_install_all() {
use static-libs || find "${ED}" -name 'lib*.la' -delete
- # If we have a GNU userland, we probably have sys-apps/man-pages
- # installed, which means we want to rename our copies #503162.
- # The use of USELAND=GNU is kind of a hack though ...
- if use userland_GNU ; then
- cd "${ED}"/usr/share/man || die
- local f
- for f in man*/*.[0-9] ; do
- mv "${f}" "${f%/*}/${PN}-${f#*/}" || die
- done
- fi
+ # we need to rename our copies #503162
+ cd "${ED}"/usr/share/man || die
+ local f
+ for f in man*/*.[0-9] ; do
+ mv "${f}" "${f%/*}/${PN}-${f#*/}" || die
+ done
}