summaryrefslogtreecommitdiff
path: root/dev-libs/libjodycode/libjodycode-2.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libjodycode/libjodycode-2.0.1.ebuild')
-rw-r--r--dev-libs/libjodycode/libjodycode-2.0.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libjodycode/libjodycode-2.0.1.ebuild b/dev-libs/libjodycode/libjodycode-2.0.1.ebuild
new file mode 100644
index 000000000000..aa0af302dd24
--- /dev/null
+++ b/dev-libs/libjodycode/libjodycode-2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shared code used by several utilities written by Jody Bruchon"
+HOMEPAGE="https://github.com/jbruchon/libjodycode"
+SRC_URI="https://github.com/jbruchon/libjodycode/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# missing test script
+# https://github.com/jbruchon/jdupes/issues/191
+RESTRICT="test"
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ LIB_DIR="/usr/$(get_libdir)" \
+ PREFIX="${EPREFIX}"/usr \
+ install
+ einstalldocs
+}