summaryrefslogtreecommitdiff
path: root/dev-libs/libnl/libnl-3.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnl/libnl-3.5.0.ebuild')
-rw-r--r--dev-libs/libnl/libnl-3.5.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-libs/libnl/libnl-3.5.0.ebuild b/dev-libs/libnl/libnl-3.5.0.ebuild
index bb1b8fad31e2..16c5e65ab3f0 100644
--- a/dev-libs/libnl/libnl-3.5.0.ebuild
+++ b/dev-libs/libnl/libnl-3.5.0.ebuild
@@ -19,7 +19,7 @@ S="${WORKDIR}/${LIBNL_P}"
LICENSE="LGPL-2.1 utils? ( GPL-2 )"
SLOT="3"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+debug static-libs python test +threads utils"
+IUSE="+debug python test utils"
RESTRICT="!test? ( test )"
RDEPEND="python? ( ${PYTHON_DEPS} )"
@@ -68,10 +68,9 @@ src_prepare() {
multilib_src_configure() {
econf \
+ --disable-static \
$(multilib_native_use_enable utils cli) \
- $(use_enable debug) \
- $(use_enable static-libs static) \
- $(use_enable threads)
+ $(use_enable debug)
}
multilib_src_compile() {